Page MenuHomePhabricator

Fix https://pt.wikibooks.org/wiki/Wikilivros:Plant%C3%A3o_de_d%C3%BAvidas
Closed, ResolvedPublic

Description

Fix https://pt.wikibooks.org/wiki/Wikilivros:Plant%C3%A3o_de_d%C3%BAvidas , https://pt.wikibooks.org/wiki/Wikilivros:Plant%C3%A3o_de_d%C3%BAvidas/Arquivo_LQT_1 , https://pt.wikibooks.org/wiki/Wikilivros:Plant%C3%A3o_de_d%C3%BAvidas/Arquivo_LQT_1/Arquivo_LQT_1 .

We believe this was caused by the following:

  1. Script was interrupted (due to using /LQT_Archive_1 in English on a Portuguese wiki; see T117616: Allow config of archive page title formats for LQT conversion using MediaWiki namespace config page).
  2. Archive page was manually moved.
  3. Script was re-run, and the page was re-moved and re-imported since it was still considered a LQT-on page.

There is code to detect this resume case, but it only handles cases where the Flow user is the last user to move the archive page.

Basic plan:

  1. Move https://pt.wikibooks.org/wiki/Wikilivros:Plant%C3%A3o_de_d%C3%BAvidas -> https://pt.wikibooks.org/wiki/Wikilivros:Plant%C3%A3o_de_d%C3%BAvidas/Temporary (or Portuguese equivalent) without leaving a redirect.
  2. Move https://pt.wikibooks.org/wiki/Wikilivros:Plant%C3%A3o_de_d%C3%BAvidas/Arquivo_LQT_1 -> https://pt.wikibooks.org/wiki/Wikilivros:Plant%C3%A3o_de_d%C3%BAvidas without leaving a redirect.
  3. Move https://pt.wikibooks.org/wiki/Wikilivros:Plant%C3%A3o_de_d%C3%BAvidas/Arquivo_LQT_1/Arquivo_LQT_1 -> https://pt.wikibooks.org/wiki/Wikilivros:Plant%C3%A3o_de_d%C3%BAvidas/Arquivo_LQT_1 without leaving a redirect.

(above ensures anyone using the page in the next hours uses the one we're planning to keep).

  1. Revert changes to the posts that redirect to these topics (e.g. https://pt.wikibooks.org/w/index.php?title=T%C3%B3pico:Wikilivros:Pergunte_ao_bibliotec%C3%A1rio/Estrutura_de_um_livro_sobre_idiomas&redirect=no ).
  2. Remove {{#useliquidthreads:0}} from https://pt.wikibooks.org/wiki/Wikilivros:Plant%C3%A3o_de_d%C3%BAvidas/Arquivo_LQT_1.
  3. Force-resume using script like P944.
  4. Put back {{#useliquidthreads:0}}.
  5. Delete duplicate topics (they should be easily identifiable since they'll be redirects (which appear as blank posts)).
  6. Delete https://pt.wikibooks.org/wiki/Wikilivros:Plant%C3%A3o_de_d%C3%BAvidas/Temporary after confirming everything re-imported correctly to the real page .

Event Timeline

Mattflaschen-WMF updated the task description. (Show Details)
Mattflaschen-WMF raised the priority of this task from to High.
Mattflaschen-WMF claimed this task.
Mattflaschen-WMF updated the task description. (Show Details)
Mattflaschen-WMF set Security to None.
Mattflaschen-WMF updated the task description. (Show Details)
Mattflaschen-WMF added a comment.EditedNov 3 2015, 2:49 AM

Or we could just re-import the whole page, then delete the duplicate topics.

Not as elegant, but less error-prone (not positive, but I think I did something similar to the "whole page" version for a page on MediaWiki.org).

Mattflaschen-WMF added a comment.EditedNov 3 2015, 8:58 PM

We decided to do the latter plan, so updated. This page was only converted because of {{useliquidthreads:1}} (see diff), and is complete as far as the script is concerned.

It's not a talk page, so we can do it while the script is running. It won't conflict, since the remaining part for the script is the rest of the talk namespaces.

It worked except for https://pt.wikibooks.org/wiki/Topic:R1rhcfgazv10jnj3 which didn't re-import to the new location (probably because the original topic was a LQT move marker, then converted to a redirect, and I couldn't revert it). That is just a pointer template, so I put it in by hand:

https://pt.wikibooks.org/wiki/Topic:Ss0yqvjrjplvivpa

Mattflaschen-WMF updated the task description. (Show Details)

@Catrope did the final deletions, so this should be fixed.

Mattflaschen-WMF closed this task as Resolved.