Page MenuHomePhabricator

Special:Watchlist shows nonfunctional RCMaxAge option in time dropdown menu
Closed, InvalidPublic

Description

since https://gerrit.wikimedia.org/r/#/c/149268/, there is a dropdown menu for selecting the max age of the changes shown in the watchlist. Additional to the seven options defined in SpecialWatchlist.php (1, 2, 6, 12 hours; 1, 3, 7 days), there is an option '30' which is the $wgRCMaxAge, but is not defined in cutoffselector function of SpecialWatchlist.php and therefore nonfunctional. If you select the '30' in the dropdown and click 'apply', '&days=' is simply set to zero.

I am no MediaWiki expert but I had a look in the SpecialWatchlist.php change and spotted the following:
Code before the change (cutoffLinks function)

global $wgRCMaxAge;
$watchlistMaxDays = ceil( $wgRCMaxAge / ( 3600 * 24 ) );

$hours = array( 1, 2, 6, 12 );
$days = array( 1, 3, 7, $watchlistMaxDays );

Code after the change (cutoffselector function):

$hours = array( 1, 2, 6, 12 );
$days = array( 1, 3, 7 );

Maybe the $watchlistMaxDays got lost mistakenly?

Related Objects

View Standalone Graph
This task is connected to more than 200 other tasks. Only direct parents and subtasks are shown here. Use View Standalone Graph to show more of the graph.

Event Timeline

hgzh created this task.Nov 20 2015, 5:22 PM
hgzh raised the priority of this task from to Normal.
hgzh updated the task description. (Show Details)
hgzh added a project: MediaWiki-Watchlist.
hgzh added a subscriber: hgzh.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 20 2015, 5:22 PM

I can't reproduce this issue. If I select the option "all" in the dropdown, I am correctly shown all the edits, up to the $wgRCMaxAge limit.

matmarex closed this task as Declined.Dec 3 2015, 4:14 PM
matmarex claimed this task.

Please reopen if you can reproduce the problem. I think it works correctly.

matmarex changed the task status from Declined to Invalid.Dec 3 2015, 4:14 PM