[Regression pre-wmf.8] Insert a mention in any Flow editor (in VE mode) is broken (on master)
Closed, ResolvedPublic1 Story Points

Description

When I try to insert a mention using the mention editor in VE, the mention appears to be there but it is not displayed.

The API call to retrieve the visual representation returns the following error:

{"error":{"code":"(curl error: 7)","info":"docserver-http-error: (curl error: 7)","*":"See http://127.0.0.1:8080/w/api.php for API usage"}}
SBisson created this task.Nov 27 2015, 7:40 PM
SBisson updated the task description. (Show Details)
SBisson raised the priority of this task from to Needs Triage.
SBisson added subscribers: SBisson, Catrope.
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptNov 27 2015, 7:40 PM
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald Transcript
Jdforrester-WMF renamed this task from Insert a mention in any Flow editor (in VE mode) is broken (on master) to [Regression pre-wmf.8] Insert a mention in any Flow editor (in VE mode) is broken (on master).Dec 1 2015, 8:25 PM
Jdforrester-WMF triaged this task as High priority.
Jdforrester-WMF edited a custom field.
Jdforrester-WMF moved this task from To Triage to TR0: Interrupt on the VisualEditor board.

I get

load.php?debug=false&lang=en-gb&modules=ext.flow.visualEditor|ext.visualEditor.base%2Ccore%2Cstanda…:15521
Uncaught TypeError: Cannot read property 'operations' of null

  • ve.ce.Surface.handleObservedChanges @ load.php?debug=false&lang=en-gb&modules=ext.flow.visualEditor|ext.visualEditor.base%2Ccore%2Cstanda…:15521
  • ve.ce.SurfaceObserver.pollOnceInternal @ load.php?debug=false&lang=en-gb&modules=ext.flow.visualEditor|ext.visualEditor.base%2Ccore%2Cstanda…:16157
  • ve.ce.SurfaceObserver.pollOnce @ load.php?debug=false&lang=en-gb&modules=ext.flow.visualEditor|ext.visualEditor.base%2Ccore%2Cstanda…:16137
  • ve.ce.SurfaceObserver.timerLoop @ load.php?debug=false&lang=en-gb&modules=ext.flow.visualEditor|ext.visualEditor.base%2Ccore%2Cstanda…:16112
This comment was removed by Catrope.
Jdforrester-WMF raised the priority of this task from High to Unbreak Now!.Dec 3 2015, 11:46 PM

I reproduced the curl error locally, and it was caused by me not having RESTbase running. (I suppose VE can probably be configured to not need RB, but I didn't bother, I just started it.) Once I started RB, I got the error that James got.

Change 257025 had a related patch set uploaded (by Catrope):
Fix JS error when unselected GeneratedContentNode rerenders

https://gerrit.wikimedia.org/r/257025

Catrope claimed this task.Dec 4 2015, 11:25 PM
Catrope lowered the priority of this task from Unbreak Now! to Needs Triage.
Catrope lowered the priority of this task from Unbreak Now! to Needs Triage.
Catrope lowered the priority of this task from Unbreak Now! to Needs Triage.
Catrope triaged this task as Unbreak Now! priority.

Change 257025 merged by jenkins-bot:
Fix JS error when unselected GeneratedContentNode rerenders

https://gerrit.wikimedia.org/r/257025

checked in betalabs.

Jdforrester-WMF closed this task as Resolved.Dec 7 2015, 8:10 PM
Jdforrester-WMF removed a project: Patch-For-Review.