Page MenuHomePhabricator

Unable to commit translations with defaultbranch=dev in Gather and RelatedArticles
Closed, ResolvedPublic

Description

Translatewiki.net is unable to commit translations with defaultbranch=dev

Todays export I323ca987a79bf755b71a8ff0a1922376a695f676 abandoned due to a path conflict.

Extension disabled for translation for now with I7408baae6c0b864ee23cba712c4c95c06f36005d

Event Timeline

Raymond raised the priority of this task from to Needs Triage.
Raymond updated the task description. (Show Details)
Raymond added a subscriber: Raymond.

I think this is because the master branch is out of date and the dev branch is still being worked on, as a result of our release process [1] (will soon be merged into master) and the i18n patches are being built against master.

Could someone tell me a few things:

  1. When the i18n bot creates its patch does it pull from the default branch or automatically from master? If the latter could it be changed to the former? Ideally when we are developing new features we'd like to get those out asap.
  2. Am I allowed to manually rebase one of the i18n bots changes when such conflicts happen?
  3. Can we turn the bot back on? I'm keen for us to get translations into the dev branch.

[1]
https://www.mediawiki.org/wiki/Reading/Web/Release_process

I think this is because the master branch is out of date and the dev branch is still being worked on, as a result of our release process [1] (will soon be merged into master) and the i18n patches are being built against master.

Could someone tell me a few things:

  1. When the i18n bot creates its patch does it pull from the default branch or automatically from master? If the latter could it be changed to the former? Ideally when we are developing new features we'd like to get those out asap.

Translatewiki.net and it's bots rely on master. In case of dev or other branches it it not defined what happen.

  1. Am I allowed to manually rebase one of the i18n bots changes when such conflicts happen?

Feel free

  1. Can we turn the bot back on? I'm keen for us to get translations into the dev branch.

Such merge conflicts like yesterday breaks the scripts of translatewiki.net and the whole process stops. So I can not re-enable the extension for now. Sorry.

I think this is because the master branch is out of date and the dev branch is still being worked on, as a result of our release process [1] (will soon be merged into master) and the i18n patches are being built against master.

Could someone tell me a few things:

  1. When the i18n bot creates its patch does it pull from the default branch or automatically from master? If the latter could it be changed to the former? Ideally when we are developing new features we'd like to get those out asap.

Translatewiki.net and it's bots rely on master. In case of dev or other branches it it not defined what happen.

This seems unfortunate. How can we fix this? It should honour .gitreview as this is delaying getting translations out to users and requesting possibly out of date ones.
@siebrand is that something we could tweak?

  1. Am I allowed to manually rebase one of the i18n bots changes when such conflicts happen?

Feel free

  1. Can we turn the bot back on? I'm keen for us to get translations into the dev branch.

Such merge conflicts like yesterday breaks the scripts of translatewiki.net and the whole process stops. So I can not re-enable the extension for now. Sorry.

The relevant scripts are here: http://git.wikimedia.org/tree/translatewiki.git/master/bin

repoupdate, repoexport, repocommit
Grep for > elif [ "$PROJECT" = "mediawiki-extensions" ]

It seems we have two options here:

  1. We ensure that translations are pulled and pushed to the master branch

Disadvantages:

  • Features in development do not get translations until they are pushed to master
  • When doing releases we will have to handle merge conflicts

Advantages:

  • No need to do empty releases which simply contain i18n messages
  1. We make translations pull and push from/to dev branch

Disadvantages:

  • Translations require someone to do a release. This is just a case of repository maintainers having better discipline. Danger i18n messages will not ride the train as early as possible.

Advantages:

  • New features when they hit production are less likely to have incomplete translations
  • New features get translations ASAP
  • Translations do not waste time translating messages that will soon be removed

The better option seems to be option 2.

So really the question for me is how to update translatewiki tooling. I'm a bit lost to be honest.

Would anyone be able to sit down with me and go through this?
It seems to be pushing to the dev branch just fine, so this is likely to be the problem:

  • When making the patch, it uses the current json of master rather than the default dev branch

Can someone walk me through this codebase or even better someone who knows it help me fix this. Happy to pair if that helps.

It seems we have two options here

There is at least a third option:

  1. Use master for development.
Jdlrobson renamed this task from Unable to commit translations with defaultbranch=dev to Unable to commit translations with defaultbranch=dev in Gather and RelatedArticles - translatewiki scripts should respect default branch .Dec 28 2015, 5:58 PM
Jdlrobson added a project: Gather.

Can someone walk me through this codebase or even better someone who knows it help me fix this. Happy to pair if that helps.

Bump. Who even maintains the translatewiki bot? This is not clear to me right now.

Bump. Who even maintains the translatewiki bot? This is not clear to me right now.

Translatewiki.net volunteer staff. In case it wasn't clear, satisfying this feature request is not a priority for TWN. If you want a fix, you will have to make one yourself. The translatewiki repository is in gerrit, if you want some modifications there, and https://translatewiki.net/wiki/Repository_management explains some of the software involved.

Change 264291 had a related patch set uploaded (by Siebrand):
[WIP] Giving bug T120581 a go here

https://gerrit.wikimedia.org/r/264291

Maybe if you create anoth branch that would be master branch but different name and leave the master branch for i18n updates backporting to the dev branch. That would be a way around the limitations.

20.13 < grrrit-wm> (Merged) jenkins-bot: Make the master branch default [extensions/QuickSurveys] - https://gerrit.wikimedia.org/r/266550
20.13 < grrrit-wm> (Merged) jenkins-bot: Make the master branch default [extensions/Cards] - https://gerrit.wikimedia.org/r/266552 (owner:
20.13 < grrrit-wm> (Merged) jenkins-bot: Make the master branch default [extensions/Gather] - https://gerrit.wikimedia.org/r/266554 (owner:
20.13 < grrrit-wm> (Merged) jenkins-bot: Make the master branch default [extensions/RelatedArticles] - https://gerrit.wikimedia.org/r/266555

I guess export can be re-enabled?

I guess export can be re-enabled?

Yep. Would be nice to fix the root cause, though, which is what I submitted a WIP patch for that will be looked into further.

Nemo_bis renamed this task from Unable to commit translations with defaultbranch=dev in Gather and RelatedArticles - translatewiki scripts should respect default branch to Unable to commit translations with defaultbranch=dev in Gather and RelatedArticles.Jan 28 2016, 10:56 AM
Nemo_bis closed this task as Resolved.
Nemo_bis removed Jdlrobson as the assignee of this task.
Nemo_bis edited projects, added Gather, RelatedArticles; removed translatewiki.net.

Change 264291 abandoned by Siebrand:
Use .gitreview's defaultbranch

Reason:
There are no use cases at the moment, so I'm not merging this now. Could be merged if we ever need it...

https://gerrit.wikimedia.org/r/264291