Page MenuHomePhabricator

No duplicate warnings are ever produced for chunked uploads to stash
Closed, ResolvedPublic

Description

No duplicate warnings are ever produced for chunked uploads.

To reproduce, check "Chunked uploads for files over 5 MB in Upload Wizard" in Commons preferences, then try uploading such a file that has a copy on Commons (e.g. https://commons.wikimedia.org/wiki/File:Baden-Baden_10-2015_img41_Pump_house.jpg).

Event Timeline

Restricted Application added a project: Multimedia. · View Herald TranscriptMar 21 2016, 11:18 PM
Restricted Application added subscribers: Steinsplitter, Aklapper. · View Herald Transcript
matmarex renamed this task from No duplicate warnings are ever produced for chunked uploads to No duplicate warnings are ever produced for chunked uploads to stash.Mar 21 2016, 11:22 PM
Restricted Application added a subscriber: Matanya. · View Herald TranscriptMar 21 2016, 11:22 PM

In UploadWizard, these fail later with a different error code, after the user fills in the description and stuff:
select left(timestamp,6), count(*) from UploadWizardErrorFlowEvent_11772725 where event_code like 'upload-error-duplicate%' group by left(timestamp,6);

+-------------------+----------+
| left(timestamp,6) | count(*) |
+-------------------+----------+
| 201504            |       96 |
| 201505            |      467 |
| 201506            |      250 |
| 201507            |      206 |
| 201508            |      424 |
| 201509            |      472 |
| 201510            |      107 |
| 201511            |      142 |
| 201512            |       86 |
| 201601            |      109 |
| 201602            |      174 |
| 201603            |      215 |
+-------------------+----------+
12 rows in set (0.16 sec)
jayvdb added a subscriber: jayvdb.Mar 22 2016, 1:46 AM
Anomie added a subscriber: Anomie.

For MediaWiki-API I'd close this as invalid as written, since the warning is in fact produced when the chunked upload is eventually "committed" as an upload-from-stash. But since this seems to actually be intended as an UploadWizard bug, I'll just remove the tag instead.

For MediaWiki-API I'd close this as invalid as written, since the warning is in fact produced when the chunked upload is eventually "committed" as an upload-from-stash.

Yeah, but what's the point of printing warnings when you've already published that file? They're supposed to warn you before you do it. In UploadWizard, we want to display them before we allow the user to publish the file, but the only way to get them after completing the upload to stash is to attempt publishing.

I'm pretty sure this is actually an API issue, but don't worry, I'll be fixing it myself.

matmarex triaged this task as Normal priority.Apr 9 2016, 2:26 PM
matmarex raised the priority of this task from Normal to High.Apr 15 2016, 3:42 PM
matmarex lowered the priority of this task from High to Normal.Apr 26 2016, 8:37 PM

Change 305284 had a related patch set uploaded (by Bartosz Dziewoński):
Check for warnings for assembled file after a chunked upload

https://gerrit.wikimedia.org/r/305284

Change 305284 merged by jenkins-bot:
Check for warnings for assembled file after a chunked upload

https://gerrit.wikimedia.org/r/305284

matmarex closed this task as Resolved.Aug 19 2016, 6:09 PM
matmarex edited projects, added MediaWiki-API; removed Patch-For-Review.

Funnily, just as I was finally fixing this, someone reported a problem where this was the underlying issue: https://commons.wikimedia.org/wiki/Commons:Upload_help#File_from_Flickr