Page MenuHomePhabricator

Page freezes/failures for Safari 6 users
Closed, ResolvedPublic

Description

Safari 6.1.6 users are reporting that their contributions, watchlist and history pages are not loading for them, freezing etc.

For quite a while now, ever since the last big update, when I try to bring up my Watchlist it takes ages - much MUCH longer than bringing up Contributions or getting to the Main Page. But this afternoon I have been unable to even get to my Watchlist
User: Shearonink

I'm having this problem too, Safari 6.1.6 (yes, I know, haven't updated). I managed to log on using Chrome, deleted my watchlist, then tried logging in with Safari and had no problem. I started reloading the watchlist a bit at a time, and after adding all the As, which was okay, then the Bs and then I got a message telling me there are too many pages to load (the entire watchlist - all of it – is barely over 2000, so As and Bs is a small number).
Victoria

Yes, I can't see my contributions page either.
Richard75

Since yesterday I've gone from being unable to view the watchlist, contribs, page histories, spent many hours trying to troubleshoot, and now get a complete freeze trying to log in.
Victoria (tk)

Details

Related Gerrit Patches:

Event Timeline

TheDJ created this task.Apr 30 2016, 5:37 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 30 2016, 5:37 PM
TheDJ added a comment.May 1 2016, 9:14 AM

This is a repeat of T110716

TheDJ added a subscriber: Amire80.May 1 2016, 9:17 AM

Introduced by change Id49c53ca6a5ec5a7a0b87c297f47e1fbe822d1fc

TheDJ added a comment.May 1 2016, 9:25 AM

I suggest avoiding -webkit-isolate and relying on the unprefixed css property. Chrome has had the unprefixed version since 48.0 (January 2016).

I know that Chrome has "isolate" already, but wanted to stay with "-webkit" for a while just in case.

If removing "-webkit-isolate", but keeping "isolate" solves this bug, I'm happy to remove it.

TheDJ added a comment.May 1 2016, 9:33 AM

yeah, this bug is just too rough, even if we were to drop this set of older browsers from Modern down to Basic, "usable" is still the minimal requirement :)

Change 286297 had a related patch set uploaded (by Amire80):
Removing unicode-bidi: -webkit-isolate

https://gerrit.wikimedia.org/r/286297

Nnemo added a subscriber: Nnemo.May 1 2016, 5:54 PM
Nnemo added a comment.May 1 2016, 6:02 PM

For a few days, I have been encountering bad experience with MediaWiki history page, for instance the history page of "molar pregnancy" on en.wikipedia.org.

The page loads, without end, and the whole Web browser Safari freezes. On iOS 7.1.2 on iPad mini.

This is probably a regression.

Is this issue here what I encounter?

What is the cause?

It would be very nice to fix that.

Thank you.

Change 286297 merged by jenkins-bot:
Removing unicode-bidi: -webkit-isolate

https://gerrit.wikimedia.org/r/286297

TheDJ added a comment.EditedMay 2 2016, 5:48 PM

@Nnemo yes, this is likely the issue that you are encountering

TheDJ added a comment.EditedMay 9 2016, 10:55 AM

It seems that this crash is fixed in Safari 9, but there it is incorrectly measuring the width of .comment elements in lists such as Special:NewPage Special:RecentChanges etc. causing overflows that should not be there... I have reported this with WebKit and it is tracked as issue 157471

Since wmf.23 is delayed, maybe I should SWAT this.

TheDJ closed this task as Resolved.May 11 2016, 9:58 PM
TheDJ claimed this task.

Solved and deployed.