[Regression] data-ve-clipboard-key span inserted in page
Closed, DuplicatePublic8 Story Points

Esanders created this task.May 8 2016, 11:55 AM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptMay 8 2016, 11:55 AM
Danny_B renamed this task from [regression] data-ve-clipboard-key span inserted in page to data-ve-clipboard-key span inserted in page.May 8 2016, 1:55 PM
Danny_B added a project: Regression.

Change 287443 had a related patch set uploaded (by Esanders):
Don't write clipboard key to custom clipboard if already in HTML

https://gerrit.wikimedia.org/r/287443

Hard to know for sure without a reproducible test case, but the above patch address a theoretical issue with a browser that fails our test for "supports custom mime types" but actually does.

Change 287443 merged by jenkins-bot:
Don't write clipboard key to custom clipboard if already in HTML

https://gerrit.wikimedia.org/r/287443

Elitre added a subscriber: Elitre.May 9 2016, 12:07 PM
Jdforrester-WMF renamed this task from data-ve-clipboard-key span inserted in page to [Regression] data-ve-clipboard-key span inserted in page.May 9 2016, 2:51 PM
Jdforrester-WMF closed this task as Resolved.
Jdforrester-WMF triaged this task as Normal priority.
Jdforrester-WMF assigned this task to Esanders.
Jdforrester-WMF set the point value for this task to 8.
Whatamidoing-WMF reopened this task as Open.Jun 17 2016, 8:49 PM

This still seems to be happening, even though that patch should have been deployed by now. Here's an interesting pattern:

Again:

Whatamidoing-WMF added a comment.EditedJun 17 2016, 9:09 PM

This is also an interesting diff: https://en.wikipedia.org/w/index.php?title=Vladimir_Bukovsky_bibliography&diff=prev&oldid=722022505

It seems to add only ref tags (which is difficult) and the span tag around existing text.