Page MenuHomePhabricator

Echo (cross-wiki): First of multiple alerts not shown.
Closed, ResolvedPublic

Description

On mediawiki.org in latest Chrome on Mac. Notifications from other wikis enables.

The alerts icon in the personal toolbar showed a 3. (Though grey, not red. When the notification is from the local wiki it shows red. Not sure this is on purpose but it seemed somewhat arbitrary to me.)

When opening the alerts drawer, it again mentions there are three, and it mentions the three wikis. In actual rendering below that only 2 notifications are shown. There is an empty section for the first wiki mentioned.

After clicking on the empty section nothing happens. Reloading the page results in the number having gone down to two. Now the same problems happens with the first one of this. The notification previously shown is now hidden.

Event Timeline

Krinkle created this task.May 13 2016, 12:00 AM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptMay 13 2016, 12:00 AM
Krinkle renamed this task from Echo (cross-wiki): First of multiple notifications not shown. to Echo (cross-wiki): First of multiple alerts not shown..May 13 2016, 12:02 AM

Change 288558 had a related patch set uploaded (by Catrope):
Protect against some errors that apparently happen in production

https://gerrit.wikimedia.org/r/288558

Change 288558 merged by jenkins-bot:
Protect against some errors that apparently happen in production

https://gerrit.wikimedia.org/r/288558

Change 288704 had a related patch set uploaded (by Catrope):
Protect against some errors that apparently happen in production

https://gerrit.wikimedia.org/r/288704

Change 288704 merged by jenkins-bot:
Protect against some errors that apparently happen in production

https://gerrit.wikimedia.org/r/288704

Restricted Application added a subscriber: JEumerus. · View Herald TranscriptMay 16 2016, 4:02 PM