Page MenuHomePhabricator

Some cross-wiki notifications are blank in the flyout, but only at some wikis
Closed, ResolvedPublic

Description

I'm seeing erratic gaps, in what appears within the cross-wiki notifications.

E.g.
At Eswiki, the items for "mediawiki" and "testwiki" are blank (missing/empty).


At Frwiki, the "Norwegian" section is blank

At Dewiki, the "testwiki" and "Goan Konkani" sections are blank.

It is consistent if I reload the page.

Event Timeline

Quiddity created this task.May 13 2016, 5:47 PM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptMay 13 2016, 5:47 PM

Change 288649 had a related patch set uploaded (by Sbisson):
Handle empty foreign notification sources

https://gerrit.wikimedia.org/r/288649

Change 288649 merged by jenkins-bot:
Handle empty foreign notification sources

https://gerrit.wikimedia.org/r/288649

Note, this is an accidental duplicate of T135196: Echo (cross-wiki): First of multiple alerts not shown. - I'm not sure which direction to merge, because both have patches attached.

Note, this is an accidental duplicate of T135196: Echo (cross-wiki): First of multiple alerts not shown. - I'm not sure which direction to merge, because both have patches attached.

And both fix different aspects of the problem. We can keep them both. They'll go to QA pretty soon.

Change 288705 had a related patch set uploaded (by Catrope):
Handle empty foreign notification sources

https://gerrit.wikimedia.org/r/288705

Change 288705 merged by jenkins-bot:
Handle empty foreign notification sources

https://gerrit.wikimedia.org/r/288705

Change 288705 merged by jenkins-bot:
Handle empty foreign notification sources
https://gerrit.wikimedia.org/r/288705

This patch is deployed now, so it should be fixed. Let us know if it still happens.

You may still see cases where we say you have notifications from MediaWiki.org, but then don't show you any notifications from MediaWiki.org. I believe this is related to T73489: Echo: Special:Notifications Exception from line of : DateTimeZone::__construct(): Unknown or bad timezone (+00:00), which I'll try to fix now.

This patch is deployed now, so it should be fixed. Let us know if it still happens.

The sections that weren't fully loading are now hidden, but ideally they should be loaded (instead of hidden).

E.g.
frwiki tells me about the notification from Svwiki (which I "marked as unread" a few hours ago), but the entry itself is now hidden (instead of blank/unloaded).

Yes, the patch hides the problem rather than fixing it. You're probably running into T73489 or some variant thereof. I'll look at the notification you marked as unread on svwiki to see what it is and if it's related to that bug or something else.

It looks like the actual issue is caused by token validation failures. The logs show lots of entries like:

mw1137 eswiki 1.28.0-wmf.1 Echo WARNING: Failed to fetch notifications from arwikisource.
Response: 200 a:2:{s:8:"servedby";s:6:"mw1119";s:5:"error";a:3:{s:4:"code";s:8:"badtoken";s:4:"info";s:33:"The centralauthtoken is not valid";s:1:"*";s:53:"See https://ar.wikisource.org/w/api.php for API usage";}} {"wiki":"arwikisource","code":200,"response":"a:2:{s:8:\"servedby\";s:6:\"mw1119\";s:5:\"error\";

Change 288722 had a related patch set uploaded (by Catrope):
Don't reuse CentralAuth tokens for multiple requests

https://gerrit.wikimedia.org/r/288722

Change 288722 merged by jenkins-bot:
Don't reuse CentralAuth tokens for multiple requests

https://gerrit.wikimedia.org/r/288722

Change 288729 had a related patch set uploaded (by Catrope):
Don't reuse CentralAuth tokens for multiple requests

https://gerrit.wikimedia.org/r/288729

Change 288729 merged by jenkins-bot:
Don't reuse CentralAuth tokens for multiple requests

https://gerrit.wikimedia.org/r/288729

This should be fixed now. @Quiddity sent me 13 cross-wiki notifications. Before this fix, I could only see 6 at a time, now I see all of them.

Restricted Application added a subscriber: JEumerus. · View Herald TranscriptMay 16 2016, 4:05 PM
Quiddity closed this task as Resolved.May 16 2016, 4:08 PM