Page MenuHomePhabricator

Undefined class constant 'TYPE_PROJECT_COLUMN'
Closed, ResolvedPublic

Description

>>> UNRECOVERABLE FATAL ERROR <<<

Undefined class constant &#039;TYPE_PROJECT_COLUMN&#039;

/srv/deployment/phabricator/deployment-cache/revs/7dd45143c333b8fb854b8f40bd96c46ea56a0970/libext/Sprint/src/storage/BoardDataProvider.php:171

Event Timeline

Danny_B created this task.May 30 2016, 12:35 AM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptMay 30 2016, 12:35 AM

Where does this happen? URL?

Check your Phabricator installation. This was patched months ago. See:

updates to upstream 46fb646f92b12a0031105d9fc9d67df67f86dcd
Bug:T132239 Change-Id: Ie407f643af7553db4d55ce0353c7399e1ad2b7e5

const TYPE_COLUMNS = 'core:columns'; was added to PhabricatorTransactions 16.04.2016
See https://secure.phabricator.com/D15634

Danny_B added a subscriber: mmodell.
Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptMay 30 2016, 1:43 AM

Please provide steps to reproduce and version info for both Phabricator and the extension.

This Phabricator obviously.

Click on any burdown chart in Sprint list.

This Phabricator obviously.

That was not obvious at all...

Click on any burdown chart in Sprint list.

I assume you mean https://phabricator.wikimedia.org/project/sprint/ and yes I can reproduce. Thanks for clarifying!

This Phabricator obviously.

That was not obvious at all...

We use any other Phabricator?

Click on any burdown chart in Sprint list.

I assume you mean https://phabricator.wikimedia.org/project/sprint/ and yes I can reproduce. Thanks for clarifying!

Since the error message provided the exact location of the error (file and line), it's quite redundant to write more...

We use any other Phabricator?

There are several Phabricator instances on Labs used for development.

Since the error message provided the exact location of the error (file and line), it's quite redundant to write more...

No, it's not. Providing easy steps to reproduce an issue makes life much easier for whoever needs to solve the issue. The error message shows something went wrong, but the why often depends on the steps that came before it.

We use any other Phabricator?

There are several Phabricator instances on Labs used for development.

Then I would tagged it with Cloud-Services or something like that as well...
Beisdes the path mentioned in the error message is explicit enough...

Since the error message provided the exact location of the error (file and line), it's quite redundant to write more...

No, it's not. Providing easy steps to reproduce an issue makes life much easier for whoever needs to solve the issue. The error message shows something went wrong, but the why often depends on the steps that came before it.

If something is clearly missing, it is missing. That means it needs to be added...
If something was behaving oddly, unexpectedly, unconsistently etc... or if there was error occurring without exact error message which exactly says, where the error is, then it would make a sense to provide reproduction steps...

Please provide (...) version info for both Phabricator and the extension.

For future: Where to find them?

Beisdes the path mentioned in the error message is explicit enough...

Noone else than you knows if you have installed a local Phabricator instance under your favorite path and reported a bug about the Sprint extension that you locally installed. So I asked. No real need for using terms like "obviously". Or to put it as a list of steps to reproduce here:

  1. Go to https://phabricator.wikimedia.org/project/sprint/
  2. Click any "Burndown" link in the list of sprints
  3. Get the following error: [...]

Please provide (...) version info for both Phabricator and the extension.

For future: Where to find them?

I asked about version info as I initially thought this task is about some local Phabricator instance - /config/module/versions/ provides such info to admins of an instance. Not needed now that we know this is about Wikimedia Phabricator.

Beisdes the path mentioned in the error message is explicit enough...

Noone else than you knows if you have installed a local Phabricator instance under your favorite path and reported a bug about the Sprint extension that you locally installed. So I asked. No real need for using terms like "obviously". Or to put it as a list of steps to reproduce here:

  1. Go to https://phabricator.wikimedia.org/project/sprint/
  2. Click any "Burndown" link in the list of sprints
  3. Get the following error: [...]

Phabricator description says: "This is the default project for the Phabricator related tasks" - why do we have tags then?

If that was not this instance issue, I wouldn't obviously tagged it with Phabricator and provided additional info. Please stop treat and lecture me like I was a newbie. It paradoxically sounds quite odd from somebody who blocks making order out of mess here furhtermore if it's aimed to someone who is working on such cleanup. Thanks.

Let's not make processess here more bureaucratic than they already are. Thanks.

I asked about version info as I initially thought this task is about some local Phabricator instance - /config/module/versions/ provides such info to admins of an instance. Not needed now that we know this is about Wikimedia Phabricator.

The same what's above applies...

However thanks for link, it may be handy somewhen in future...

[offtopic]

Phabricator description says: "This is the default project for the Phabricator related tasks" - why do we have tags then?

Tags are to organize tasks around projects. Providing clear steps (and circumstances) to reproduce a problem is a different aspect, which is what I initially asked for as my first comment in this task.

Please stop treat and lecture me like I was a newbie.

I can't see (yet) where this has happened in this task - I see people asking for more specific information to make it easier to track down the problem, plus answering your followup questions and comments. If you've experienced "lecturing" in this task please point out specific comments and potentially move this meta-discussion to a talk page (as it's unrelated to the error message you reported in this task).

It paradoxically sounds quite odd from somebody who blocks making order out of mess here furhtermore if it's aimed to someone who is working on such cleanup. Thanks.

Sounds like personal criticism unrelated to the actual discussion in this task...

Change 291744 had a related patch set uploaded (by Paladox):
updates to upstream 46fb646f92b12a0031105d9fc9d67df67f86dcd

https://gerrit.wikimedia.org/r/291744

It was forgotten to be backported to wmf/stable branch which we use to deploy phabricator.

Done in https://gerrit.wikimedia.org/r/#/c/291744/

Thanks, it was already pointed out earlier T136531#2337898 by Christopher.

But as I understood it, this is rather regression then, as it used to work before? If not, then it is obviously a dupe and feel free to close it as such... Thanks.

@Danny_B probally worked before since we were using master branch then switched to using a wmf/stable branch a month ago I think.

Ah... Ignore the previous comment - further stuff appeared here before I submitted the comment. There are no edit conflicts here... Bugzilla used to notify such conflicts... :-/

@Danny_B I think we should keep this task open since the change was never deployed in wmf/stable branch.

move this meta-discussion to a talk page (as it's unrelated to the error message you reported in this task).

I didn't start it here (I've suggested you couple times to discuss such issues somewhere else - IRC, email, pub... ;-)) and since it is obviously unproductive at all, it doesn't even make a sense to continue in it.

@Danny_B I think we should keep this task open since the change was never deployed in wmf/stable branch.

Yup. As I mentioned above, if it is regression, then keep opened, if it never worked, close as dupe. But since I do not know how it was before, I can't do such decision...

Change 291749 had a related patch set uploaded (by Paladox):
updates to upstream 46fb646f92b12a0031105d9fc9d67df67f86dcd

https://gerrit.wikimedia.org/r/291749

Change 291744 abandoned by 20after4:
updates to upstream 46fb646f92b12a0031105d9fc9d67df67f86dcd

Reason:
I'm doing this as a merge instead of a cherry pick

https://gerrit.wikimedia.org/r/291744

Change 291749 abandoned by 20after4:
updates to upstream 46fb646f92b12a0031105d9fc9d67df67f86dcd

Reason:
production branch is obsolete

https://gerrit.wikimedia.org/r/291749

The change was merged in wmf/stable ready to be deployed. Which I think is normaly on Wednesday when we update phabricator to latest change.

mmodell closed this task as Resolved.EditedJun 9 2016, 12:34 AM
mmodell claimed this task.

I guess this is resolved. I'm really not sure how to reproduce. If it's still happening please reopen and provide instructions on how to reproduce the issue.

It doesn't appear anymore. Thanks for fixing.