Page MenuHomePhabricator

create endowment.wm.org microsite
Closed, ResolvedPublic

Description

after talking with @MBrent , we are setting up endowment.wikimedia.org for:

(https://15.wikipedia.org/endowment.html , http://blog.wikimedia.org/2016/01/14/wikipedia-15-foundation-endowment/ , https://meta.wikimedia.org/wiki/Endowment)

content will be provided by Mule Design. (http://muledesign.com/) who also did 15.wikipedia.org

subtasks for ops

  • add to DNS
  • add puppet role / code to setup as microsite on bromine
  • request Gerrit project/repo, discuss who gets +2 on it
  • let puppet clone the content from that repo
  • tell Mule to upload like last time, give them project name

...

Details

Related Gerrit Patches:
operations/dns : masterremove endowment.wikimedia.org
operations/puppet : productionremove endowment.wikimedia.org
operations/dns : masteradd endowment.wikimedia.org
operations/puppet : productionadd puppet code for endowment.wm.org site
operations/puppet : productioncache::misc add endowment.wm.org -> bromine

Event Timeline

Dzahn created this task.Jun 1 2016, 7:43 PM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 1 2016, 7:43 PM

Change 292208 had a related patch set uploaded (by Dzahn):
add endowment.wikimedia.org

https://gerrit.wikimedia.org/r/292208

Dzahn updated the task description. (Show Details)Jun 1 2016, 7:48 PM
Dzahn updated the task description. (Show Details)Jun 1 2016, 7:50 PM

Change 292210 had a related patch set uploaded (by Dzahn):
cache::misc add endowment.wm.org -> bromine

https://gerrit.wikimedia.org/r/292210

Dzahn updated the task description. (Show Details)Jun 1 2016, 7:57 PM

Change 292210 merged by Dzahn:
cache::misc add endowment.wm.org -> bromine

https://gerrit.wikimedia.org/r/292210

Do we really want to allow more microsites?

Dzahn added a comment.Jun 1 2016, 11:49 PM

Do we really want to allow more microsites?

Personally i think it would be better to use wiki. But you gotta ask MBrent's team. This is just ops creating it as a service. That said i'm happy if we can stick to something.wikmedia.org as opposed to new domain names and that external devs are going to upload to Gerrit. That's already so much better than in the past.

Change 292303 had a related patch set uploaded (by Dzahn):
add puppet code for endowment.wm.org site

https://gerrit.wikimedia.org/r/292303

Change 292303 merged by Dzahn:
add puppet code for endowment.wm.org site

https://gerrit.wikimedia.org/r/292303

Do we really want to allow more microsites?

Personally i think it would be better to use wiki. But you gotta ask MBrent's team. This is just ops creating it as a service. That said i'm happy if we can stick to something.wikmedia.org as opposed to new domain names and that external devs are going to upload to Gerrit. That's already so much better than in the past.

It's your decision to actually create it, not their's.

I think T599#11308 is relevant here.

We should at least keep a list of these micro-sites somewhere so that we can thoroughly kill them all at a later date. From browsing around Phabricator just now:

  • 15.wikipedia.org
  • annual.wikimedia.org
  • policy.wikimedia.org
  • annual.wikimedia.org
  • transparency.wikimedia.org

There are probably others.

Dzahn added a comment.Jun 2 2016, 5:06 AM

@MZMcBride In March i made an effort in that direction that also fixes puppet-lint issues at the same time, moving the microsites into a the same role structure

https://gerrit.wikimedia.org/r/#/c/275034/

so it's puppet/modules/role/manifests/microsites/

annualreport.pp endowment.pp peopleweb peopleweb.pp releases releases.pp transparency.pp

Change 292208 merged by Dzahn:
add endowment.wikimedia.org

https://gerrit.wikimedia.org/r/292208

Dzahn updated the task description. (Show Details)Jun 3 2016, 8:12 PM
Dzahn added a comment.Jun 4 2016, 1:32 AM

@MBrent done so far on our side. next step would be content from Mule and letting them know to upload just like they did for annualreport and 15.wp, the only difference is repo name is now "wikimedia/endowment"

Dzahn triaged this task as Low priority.Jun 6 2016, 8:55 PM
Dzahn closed this task as Resolved.Jun 6 2016, 9:52 PM
Dzahn updated the task description. (Show Details)

mailed Steph, Mia, Marc and Heather. Apparently both Steph and Mia don't work for Mule anymore. This worries me a bit because they were the ones already familiar with using Gerrit.

Dzahn added a comment.Jul 28 2017, 2:02 AM

is this site still being planned? it's over a year later

Dzahn reopened this task as Open.Sep 28 2017, 10:46 PM
Dzahn raised the priority of this task from Low to High.

received personal email that there is now http://wikimediaendowment.org/ and content is supposed to be hosted on Wordpress servers, while we still handle email and the time-frame is now before End of October

hi all, update from friday's call with marc, daniel, brandon and i. i'm currently working to schedule time with our wordpress VIP reps to discuss their ability to handle email for the site's dns-admin / abuse reports and the domain itself (as the endowment is a separate legal entity, though the domain is currently held by WMF). my apologies for the confusion -- i'll update this as i learn more. big thanks again for your help and patience (esp as i get started on phabricator. ;)) more soon.

Dzahn added a comment.Oct 2 2017, 5:01 PM

@kaythaney Thank you for the update. It's appreciated!:)

Change 381866 had a related patch set uploaded (by Dzahn; owner: Dzahn):
[operations/puppet@production] remove endowment.wikimedia.org

https://gerrit.wikimedia.org/r/381866

Change 381866 merged by Dzahn:
[operations/puppet@production] remove endowment.wikimedia.org

https://gerrit.wikimedia.org/r/381866

Change 381904 had a related patch set uploaded (by Dzahn; owner: Dzahn):
[operations/dns@master] remove endowment.wikimedia.org

https://gerrit.wikimedia.org/r/381904

Change 381904 merged by Dzahn:
[operations/dns@master] remove endowment.wikimedia.org

https://gerrit.wikimedia.org/r/381904

Dzahn changed the task status from Open to Stalled.Oct 12 2017, 9:40 PM

update! automatic / wordpress VIP are going to host the email for dns-admin/ abuse reports, as well as handle hosting of the domain. will know more next week about the timeline and needs from Ops -- but in the clear for now. many thanks to you all for your help (and patience).

@kaythaney Great! Sounds good, thank you. I already removed everything on our side.

Dzahn lowered the priority of this task from High to Medium.Oct 13 2017, 9:08 PM
kaythaney raised the priority of this task from Medium to High.Oct 25 2017, 2:57 PM

Hi all,

We're in the final push to get the site live with Wordpress VIP, and ready to address the DNS issue. We're looking to push this live in the next few days, if possible.

All they need is for the contents of the wikimediaendowment.org Zone file to be copied / sent over (They're working in a Zendesk ticket, linked below. I'm also happy to send over separately -- let me know what you'd prefer). This'll help them know what records to add to their system. Once that's set on their end, they can coordinate when to point the DNS to VIP.

Here's the Zendesk ticket, for reference.

https://wordpressvip.zendesk.com/hc/en-us/requests/60140?page=4#comments

Let me know if you have any questions. Happy to also add you to the Zendesk ticket, should you need access.

Big thanks in advance (and my apologies for the short notice). Appreciate any help you can provide. :)

Dzahn added a comment.Oct 25 2017, 4:01 PM

Hi @kaythaney

i think there is a misunderstanding. There is no wikimediaendowment.org zone file on our side. The domain has never existed in our DNS configuration. And since it's not going to be on our infrastructure and instead hosted by Wordpress completely, they are the ones who who would have to know what records to add.

Best,

Daniel

Dzahn added a comment.Oct 25 2017, 4:05 PM

regarding the ticket link, i was able to create an account, but after that i just get:

This support portal was recently redesigned.
The page you were looking for doesn't exist

You may have mistyped the address or the page may have moved

So i can't see the contents of that.

Dzahn added a comment.Oct 25 2017, 4:07 PM

I can see other "organization requests" created by Wikimedia in the past at https://wordpressvip.zendesk.com/hc/en-us/requests/organization but ticket 60140 is not among them.

Dzahn added a comment.Oct 25 2017, 4:08 PM

@kaythaney Either way, i don't think there is anything you need from Operations to move forward on this. There is nothing to configure on our side.

Dzahn added a comment.Oct 25 2017, 4:11 PM

I think the only thing that needs to happen is that legal (or whoever bought the domain name with MarkMonitor) contacts MarkMonitor and tells them the name servers need to be changed to Wordpress servers.

Thanks, Daniel -- and my apologies for the hassle. Let me loop in our Wordpress contacts.

  • KT
Dzahn added a comment.Oct 27 2017, 2:44 AM

@kaythaney I was now able to read the Wordpress ticket. I saw they confirmed they don't need a zone file and instead just need legal (MarkMonitor) to switch the DNS servers to Wordpress. Sounds good!

Dzahn added a comment.Nov 2 2017, 7:46 AM

Looks like the site is live now:

https://wikimediaendowment.org/

Dzahn closed this task as Resolved.Nov 2 2017, 7:46 AM

@kaythaney This is all resolved now, right?

Thanks, Dzahn. We're all set.

Legoktm added a subscriber: Legoktm.Nov 9 2017, 1:17 AM

@kaythaney where should one report bugs in the website? I noticed that the wrong MediaWiki logo is being used.

thanks! i'll update that first thing next week. (please feel free to file
tickets here and tag me, or ping me directly.)

We should at least keep a list of these micro-sites somewhere so that we can thoroughly kill them all at a later date. From browsing around Phabricator just now:

  • 15.wikipedia.org
  • annual.wikimedia.org
  • policy.wikimedia.org
  • annual.wikimedia.org
  • transparency.wikimedia.org

There are probably others.

Thanks, I created https://wikitech.wikimedia.org/wiki/Microsites now.

Does the bugzilla archive really count as a microsite? It's huge...

Dzahn added a comment.Jul 24 2018, 6:20 PM

I don't think it matters much. We could also call them "miscsites". It's just a term that tries to describe sites that are not part of normal wikis, not apps and hosted in production.