Page MenuHomePhabricator

Pagination broken on Special:PrefixIndex
Closed, ResolvedPublic

Description

https://en.wikipedia.org/w/index.php?title=Special%3APrefixIndex&prefix=A&namespace=0

There are way more pages starting with A than listed there (E.g. ABBA, Apple).

Also affects empty queries, e.g. https://az.wikipedia.org/w/index.php?title=X%C3%BCsusi%3APrefixIndex&prefix=A&namespace=8 does not list Monobook.js but stops at Gadget-*.

Details

Related Gerrit Patches:
mediawiki/core : masterFix Special:PrefixIndex paging links
mediawiki/core : wmf/1.28.0-wmf.3Fix Special:PrefixIndex paging links
mediawiki/core : wmf/1.28.0-wmf.4Fix Special:PrefixIndex paging links

Event Timeline

Krinkle created this task.Jun 1 2016, 8:10 PM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 1 2016, 8:10 PM
greg added a subscriber: greg.Jun 1 2016, 8:48 PM

@Krinkle since this affects wmf.3 and .4 (I presume), I'd rather not rollback to .2 and instead just fix/backport. Reasonable?

@greg Yep, just making sure it's traceable as a regression from wmf.3 and UBN. This should be fixed or that commit reverted as soon as possible. This is causing users to make mistakes as it appears no further pages existed, and people may make decisions based on that (e.g. when fixing all pages in the MediaWiki namespace before flipping a switch or migrating some deprecated function).

mmodell added a subscriber: mmodell.Jun 1 2016, 8:52 PM

So should we revert 1483af0c89?

greg added a comment.Jun 1 2016, 8:52 PM

Let's do it.

(made then both blocked since it'd need reverting in both)

Change 292224 had a related patch set uploaded (by Aaron Schulz):
Fix prefix index paging

https://gerrit.wikimedia.org/r/292224

Change 292228 had a related patch set uploaded (by 20after4):
Fix Special:PrefixIndex paging links

https://gerrit.wikimedia.org/r/292228

Change 292234 had a related patch set uploaded (by 20after4):
Fix Special:PrefixIndex paging links

https://gerrit.wikimedia.org/r/292234

Cherry picked to wmf.3 and wmf.4:

Change 292224 merged by jenkins-bot:
Fix Special:PrefixIndex paging links

https://gerrit.wikimedia.org/r/292224

Change 292228 merged by jenkins-bot:
Fix Special:PrefixIndex paging links

https://gerrit.wikimedia.org/r/292228

Change 292234 merged by jenkins-bot:
Fix Special:PrefixIndex paging links

https://gerrit.wikimedia.org/r/292234

Mentioned in SAL [2016-06-01T21:26:07Z] <twentyafterfour@tin> Synchronized php-1.28.0-wmf.3/includes/specials/SpecialPrefixindex.php: sync https://gerrit.wikimedia.org/r/#/c/292234/ ( T136738 ) (duration: 00m 30s)

Mentioned in SAL [2016-06-01T21:31:27Z] <twentyafterfour@tin> Synchronized php-1.28.0-wmf.4/includes/specials/SpecialPrefixindex.php: sync https://gerrit.wikimedia.org/r/#/c/292228/ ( T136738 ) (duration: 00m 26s)

Krinkle closed this task as Resolved.Jun 1 2016, 10:28 PM
Krinkle claimed this task.

Verified. Thanks!