Page MenuHomePhabricator

Upgrade kibana to 4.5.0+
Closed, ResolvedPublic

Description

The version of kibana we use in production will not work with the latest versions of elasticsearch. Specifically it uses facets which were deprecated in 1.4 and removed in 2.0. To upgrade the elasticsearch cluster supporting kibana to 2.3 (to match the search clusters) kibana 4.5.0+ is required.

Note that kibana 4 is basically a completely different application from kibana 3 that we are currently using. The only thing that stayed the same is the name and the general purpose.

Event Timeline

Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 21 2016, 4:56 PM

Change 296279 had a related patch set uploaded (by EBernhardson):
[WIP] Update kibana module for kibana 4

https://gerrit.wikimedia.org/r/296279

@Gehel I'm not sure how to go about adding a new package to the apt repo, but i'm guessing you do :)

EBernhardson closed this task as Resolved.Jul 18 2016, 10:57 PM

merged and deployed