[Discuss-Storytime][Usability] Error message should help to solve problem when assigning a non well formed URL as value to an URL-restricted property results
Closed, ResolvedPublic

Description

Story: I want to add a value to a URL-restricted property

What happens already
If the URL I type is not well formed according to the check (e.g. heise.de is not well formed) I get an error message.
It is good, usability-wise, that the problem is made clear by the color change to orange and the popup. However, the message does not help the user to recover from the error, since it is very generic. (there is details, which in this case is more specific, but it may not be used)

What should happen

(in order of assumed workload and gain from lower to higher)

  1. The error should point out the problem right away and in user-understandable language: "The value ›heise.de‹ does not look like a URL for our check, so it could not be saved."

  1. Assuming that there is a group catching Regex, it makes sense to check what exactly failed: "We could not save this, since heise.de does not look like a URL for our check: the protocol (like http://) is missing. Please correct the URL and try again"

  1. We may also tentatively just accept a value (in this case, heise.de works in any browser, including lynx) and flag is somehow as "possibly incomplete" so the user could continue and return later or allow someone else to fix it.

Usability Guidelines: User Control and Freedom, Help users recognize, diagnose, and recover from errors

Related: T138312

Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 22 2016, 8:11 AM
Jan_Dittrich updated the task description. (Show Details)Jun 22 2016, 8:12 AM
Jan_Dittrich renamed this task from Error message should help to solve problem when assigning a non well formed URL as value to an URL-restricted property results to [Usability] Error message should help to solve problem when assigning a non well formed URL as value to an URL-restricted property results.
Jan_Dittrich added a project: Design.
Lydia_Pintscher removed Lydia_Pintscher as the assignee of this task.Jul 18 2016, 1:25 PM
Lydia_Pintscher added a subscriber: Lydia_Pintscher.

Is there already a plan how this can be done? I remember that the idea was to show both of the messages. (@Jonas ?)

As far as I can remember @thiemowmde proposed to remove the toggler ('Details') .

I proposed a solution in T54843#2453317: There are three code paths. Two are technical and should not be changed (still collapsed by default). The third one is already translated and should replace the generic message.

Please make these two tickets depend on each other.

Jan_Dittrich renamed this task from [Usability] Error message should help to solve problem when assigning a non well formed URL as value to an URL-restricted property results to [Storytime-Discuss][Usability] Error message should help to solve problem when assigning a non well formed URL as value to an URL-restricted property results.Aug 16 2016, 1:33 PM
Jan_Dittrich renamed this task from [Storytime-Discuss][Usability] Error message should help to solve problem when assigning a non well formed URL as value to an URL-restricted property results to [Discuss-Storytime][Usability] Error message should help to solve problem when assigning a non well formed URL as value to an URL-restricted property results.
Jan_Dittrich renamed this task from [Storytime-Discuss][Usability] Error message should help to solve problem when assigning a non well formed URL as value to an URL-restricted property results to [Discuss-Storytime][Usability] Error message should help to solve problem when assigning a non well formed URL as value to an URL-restricted property results.
Jan_Dittrich added a subscriber: daniel.

Remark in planning: The title highlights a very specific problem while the solution is (probably) more general (@daniel , @thiemowmde )

@Jan_Dittrich, can you please rephrase the title of this ticket to not talk about URLs? As far as I understand URL fields are just one example, but there are others that have the same issue (e.g. when picking a unit for a quantity, you can type whatever you want, but only a few strings will be accepted).

For units we have a suggester. The one thing people run into again and again and where the message is the worst is the URL. So let's please fix that message now.

So I would leave it like it is. However, if there is a "deeper" change that would affect more errors (positively!), I'd be glad to help on that ticket. However, I don't know what would needed to be touched for that (It was briefly mentioned in yesterdays sprint start meeting), so I can't create it myself.

@Lydia_Pintscher, what do people run into? Based on Jans task description I assume people are trying to enter URLs without the leading "http://", because this is what they are used to from the browsers address bar. Is this all this ticket is about? Or am I missing something else?

thiemowmde triaged this task as Normal priority.
thiemowmde moved this task from Reported Wikidata to Review on the WMDE-Design board.

Change 305274 had a related patch set uploaded (by Thiemo Mättig (WMDE)):
Introduce error message for URLs that miss the leading "http://"

https://gerrit.wikimedia.org/r/305274

thiemowmde moved this task from Incoming to For Review on the Design board.Aug 17 2016, 3:34 PM

Yes exactly. Thanks a lot for the fix!

Change 305274 merged by jenkins-bot:
Introduce error message for URLs that miss the leading "http://"

https://gerrit.wikimedia.org/r/305274

Jonas moved this task from Review to Done on the Wikidata-Sprint-2016-08-16 board.Aug 19 2016, 3:04 PM
Jonas closed this task as Resolved.
Charlie_WMDE moved this task from Review to Done on the WMDE-Design board.Nov 8 2016, 4:03 PM