Page MenuHomePhabricator

[Regression pre-wmf.9] VE throws an exception in all pages due to broken namespaces array
Closed, ResolvedPublic1 Story Points

Description

Trying to load any page (Main page, Special:Notifications, etc) throws an exception in the console:

Exception in module-execute in module ext.visualEditor.desktopArticleTarget.init:
TypeError: conf.namespaces.indexOf is not a function TypeError: conf.namespaces.indexOf is not a function(…)

Event Timeline

Mooeypoo created this task.Jun 30 2016, 6:51 PM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 30 2016, 6:51 PM

Likewise - where did you see this?

Esanders triaged this task as Unbreak Now! priority.Jun 30 2016, 7:24 PM
Restricted Application added subscribers: Luke081515, TerraCodes, Urbanecm. · View Herald TranscriptJun 30 2016, 7:24 PM

Change 296810 had a related patch set uploaded (by Alex Monk):
Follow-up I9202066d: array_unique leaves gaps in keys, we need to run array_values on it afterwards

https://gerrit.wikimedia.org/r/296810

Yep it's all over beta, and is my fault

Change 296810 merged by jenkins-bot:
Follow-up I9202066d: array_unique leaves gaps in keys, we need to run array_values on it afterwards

https://gerrit.wikimedia.org/r/296810

AlexMonk-WMF closed this task as Resolved.Jun 30 2016, 9:13 PM

Thanks @Mooeypoo, and Ed for merging

Jdforrester-WMF renamed this task from VE throws an exception in all pages to [Regression pre-wmf.9] VE throws an exception in all pages due to broken namespaces array.Jul 1 2016, 9:59 AM
Jdforrester-WMF removed a project: Patch-For-Review.
Jdforrester-WMF set the point value for this task to 1.
Jdforrester-WMF moved this task from To Triage to TR0: Interrupt on the VisualEditor board.