Page MenuHomePhabricator

Give Flow board creation rights automatically to admins on the Konkani Wikipedia
Closed, ResolvedPublic

Description

On the Konkani Wikipedia (gomwiki) if we want to create a Flow board in any namespace other than Talk, then we have no option but to request help from a member of the Collaboration team. I think it would make sense to give the right 'Create Flow boards everywhere' automatically to admins on gomwiki.

Related Objects

Event Timeline

Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJul 2 2016, 6:49 AM
Restricted Application added subscribers: JEumerus, Matanya. · View Herald TranscriptJul 2 2016, 11:27 AM

Has this been discussed in gomwiki? If so, please provide a link with this discussion and consensus. Thanks.

No it hasn't been discussed on the Wikipedia. @Catrope suggested we do this when I requested him to create a flow page for me. He said that either he or @Mattflaschen-WMF will take it up.

I do not see any need to have a discussion for this on-wiki, because it's normal for admins to be able to change the content model of pages. Still, let me know, if needed, I'll post a notice on the main community page.

Okay, if you discussed it with @Catrope, I'll leave it to him. Then I think that this is for Wikimedia-Site-requests a special handling task.

Will this be secure? We've been reported problems at Meta with Flow boards which were stuck, unmovable, etc.

Will this be secure? We've been reported problems at Meta with Flow boards which were stuck, unmovable, etc.

Please provide details in a separate bug, if this is still happening. Flow boards can only be moved if you have permission to create a Flow board at the destination. This is by design, so e.g. you can't move Flow boards from a Flow namespace to a non-Flow one, unless you can create Flow boards in the non-Flow namespace.

Anyone with flow-create-board should be able to create a Flow board anywhere, or move one to anywhere.

Change 298405 had a related patch set uploaded (by Mattflaschen):
Add flow-create-board for gomwiki sysop

https://gerrit.wikimedia.org/r/298405

Change 298405 merged by jenkins-bot:
Add flow-create-board for gomwiki sysop

https://gerrit.wikimedia.org/r/298405

Mentioned in SAL [2016-07-12T23:43:55Z] <dereckson@tin> Synchronized wmf-config/InitialiseSettings.php: Add flow-create-board for gomwiki sysop (T139226) (duration: 00m 27s)

Dereckson closed this task as Resolved.Jul 13 2016, 3:11 AM
Dereckson claimed this task.