Page MenuHomePhabricator

MassMessage is no longer accepting lists in the MassMessageList content model
Closed, ResolvedPublic

Description

The Special:MassMessage function no longer appears to accept a Page containing list of pages to leave a message on, if the page is in the MassMessageList content model.

This is reproducible on enwiki and test2wiki.

Pages in wikitext format still function.

Example pages:
wikitext (works): https://en.wikipedia.org/wiki/User:Xaosflux/SandboxMMS
wikitext (works): https://test2.wikipedia.org/wiki/User:Xaosflux/SandboxMMS
MML (does not work): https://en.wikipedia.org/wiki/User:Xaosflux/SandboxMMS2
MML (does not work): https://test2.wikipedia.org/wiki/User:Xaosflux/SandboxMMS2

Event Timeline

Xaosflux created this task.Jul 4 2016, 4:57 PM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJul 4 2016, 4:57 PM
Xaosflux renamed this task from MassMessage is no longer accepting lists in the MassMessage content model to MassMessage is no longer accepting lists in the MassMessageList content model.Jul 4 2016, 5:02 PM

This is caused by https://gerrit.wikimedia.org/r/#/c/94691/, where a really old patch from pre-mmch days was revived and merged.

Aklapper triaged this task as High priority.Jul 4 2016, 6:43 PM
Aklapper added a subscriber: Legoktm.

I assume T139277 is a duplicate of this task and could be merged into this?

CC'ing @Legoktm as per last comment (author of the patch that might have introduced this regression)

Adding subscribers from enwiki WP:VPT

Change 297285 had a related patch set uploaded (by Legoktm):
Revert "Show an error to the user if the spamlist has no targets on it"

https://gerrit.wikimedia.org/r/297285

Change 297291 had a related patch set uploaded (by Legoktm):
Revert "Show an error to the user if the spamlist has no targets on it"

https://gerrit.wikimedia.org/r/297291

Change 297285 merged by jenkins-bot:
Revert "Show an error to the user if the spamlist has no targets on it"

https://gerrit.wikimedia.org/r/297285

Change 297291 merged by jenkins-bot:
Revert "Show an error to the user if the spamlist has no targets on it"

https://gerrit.wikimedia.org/r/297291

Mentioned in SAL [2016-07-04T19:57:07Z] <legoktm@tin> Synchronized php-1.28.0-wmf.8/extensions/MassMessage/: MassMessage is no longer accepting lists in the MassMessageList content model - T139303 (duration: 00m 39s)

Revert should be deployed, please let @wctaiwan know if there are any more issues :) <3

Legoktm closed this task as Resolved.Jul 4 2016, 8:02 PM
Legoktm claimed this task.

Confirmed solved on enwiki, thank you!