Page MenuHomePhabricator

Removal of {{#coordinates:}} leaves DB entries behind
Closed, InvalidPublic

Event Timeline

MaxSem created this task.Aug 18 2016, 9:30 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 18 2016, 9:30 PM
mpopov added a subscriber: mpopov.Jul 11 2017, 12:38 AM
debt triaged this task as Medium priority.Jul 11 2017, 10:17 PM
debt added projects: Discovery, Maps-Sprint.
debt added a subscriber: debt.

Moving to the Discovery / Interactive (Maps) board for tracking.

This is based on a discovery found in T170022#3423437:

...going through your discovery-stats repo and currently taking a look at the geo_tag table. I'm noticing that sometimes there are geotags in the database that are no longer present on wiki.

For example, the geotag for File:Vossloh Euro 4000 pupitre.JPG got removed: https://commons.wikimedia.org/w/index.php?title=File%3AVossloh_Euro_4000_pupitre.JPG&type=revision&diff=88315031&oldid=86196480 but it's still in the geo_tags table. Do you know if there is any script that performs maintenance on those tables? Do you know who owns the code that adds data to geo_tags when a file on Commons has a location?

Tagging DBA here because the geo_tag table grows whenever someone adds coordinates but does not shrink when coordinates are removed on-wiki and that's something they should be aware of.

Thanks for the heads up. I assume this will be fixed at some point, right?

Thanks for the heads up. I assume this will be fixed at some point, right?

Any update on this question?
Thanks

Gehel added a subscriber: Gehel.Sep 4 2017, 4:21 PM

No update... I'm not even sure who's scope this is. It does not look to be part of Kartographer or any of the project in the scope of the maps team (yes, I'm showing my ignorance). @MaxSem do you know where this {{location}} is coming from?

TheDJ added a subscriber: TheDJ.Sep 6 2017, 2:30 PM

The coordinates parser function is within the scope of the GeoData extension.

jcrespo added a subscriber: aude.Sep 6 2017, 2:32 PM
Pnorman added a subscriber: Pnorman.

Pulling off of the maps sprint, because it's not kartotherian, kartographer, or anything we're responsible for. I'm not sure who is responsible for GeoHack.

Pnorman removed a subscriber: Pnorman.Feb 27 2018, 6:35 PM

If there is not a responsible for the GeoData extension, we should start the sunsetting process.

Restricted Application added a project: Discovery-Search. · View Herald TranscriptMar 12 2020, 12:53 PM

Any update on when could someone at Discovery-Search could triage this issue? As per T188434#4128506. This issue makes incorrect information show up about certain pages, and may have some negative impact on database storage.

Do we have any working examples? The linked page has coordinates embedded into the file itself, and these are coordinates reported by the api. At least for the linked example page there doesn't appear to be any issue

jcrespo added a comment.EditedMar 12 2020, 3:43 PM

Not the original reporter, and do not know how the extension works. I added the template to a test page:

https://commons.wikimedia.org/wiki/User:JCrespo_(WMF)/test

But doesn't seem to report the coordinates (yet):

https://commons.wikimedia.org/wiki/Special:ApiSandbox#action=query&format=json&prop=coordinates&titles=User%3AJCrespo_(WMF)%2Ftest

@MaxSem Do you know if it only supposed to work on File ns?

jcrespo added a comment.EditedMar 12 2020, 3:47 PM

@MaxSem Do you know if it only supposed to work on File ns?

I answer myself, it works on a file ns:

https://commons.wikimedia.org/wiki/Special:ApiSandbox#action=query&format=json&prop=coordinates&titles=File%3ATest%20T198177.png


Will now remove it and try to reproduce the bug.

jcrespo added a comment.EditedMar 12 2020, 3:55 PM

Removed them:
https://commons.wikimedia.org/w/index.php?title=File:Test_T198177.png&diff=prev&oldid=403649969

The coords are gone from the API:

And from the DB:

Unless there is specific cases (which I cannot discard, for example, if a removal happened during an outage), I would close this as invalid/cannot reproduce. CC @MaxSem

EBernhardson closed this task as Invalid.Mar 12 2020, 4:00 PM

Sounds reasonable. Based on what I see in GeoData code, if a LinksUpdate job is lost the coordinates will remain in the database until the next edit. On the following edit it should be removed. Hopefully we don't lose many LinksUpdate jobs these days.

Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptMar 12 2020, 4:00 PM