Page MenuHomePhabricator

Pageview Spike in Tagalog Wikipedia mid-June 2016
Closed, ResolvedPublic3 Story Points

Description

According to the Pageviews API, there is a considerable increase in pageviews in the Tagalog Wikipedia in mid-June:

https://tools.wmflabs.org/siteviews/?platform=all-access&source=pageviews&agent=user&start=2015-07-01&end=2017-03-01&sites=tl.wikipedia.org

This may be just normal seasonality, but it's much higher than during the whole year before it. Also, it may be something similar to bug T141506: Suddenly outrageous higher pageviews for main pages.

Event Timeline

Amire80 created this task.Sep 2 2016, 8:16 PM
Restricted Application added a project: Analytics. · View Herald TranscriptSep 2 2016, 8:16 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Nuria added a subscriber: Nuria.Sep 2 2016, 8:32 PM

@Amire80

Issue doesn't look seasonal:
https://analytics.wikimedia.org/dashboards/vital-signs/#projects=tlwiki/metrics=Pageviews

Neither per se related to issue with Chrome 41 as spike of traffic due to TLS bug goes down
around mid August after the August 16th deployment on varnish to return 401s.
See spike going down on ruwiki:
https://analytics.wikimedia.org/dashboards/vital-signs/#projects=tlwiki,ruwiki/metrics=Pageviews

FYI that there was a mw deployment on June 12th the day this spike starts:
02:28 logmsgbot: mwdeploy@tin scap sync-l10n completed (1.28.0-wmf.5) (duration: 12m 24s)

@Amire80
Issue doesn't look seasonal:
https://analytics.wikimedia.org/dashboards/vital-signs/#projects=tlwiki/metrics=Pageviews
Neither per se related to issue with Chrome 41 as spike of traffic due to TLS bug goes down
around mid August after the August 16th deployment on varnish to return 401s.
See spike going down on ruwiki:
https://analytics.wikimedia.org/dashboards/vital-signs/#projects=tlwiki,ruwiki/metrics=Pageviews

True, but let's not forget that Chrome 41 was actually only partly responsible for the spikes in T141506. On nlwiki, the spike was instead caused by Chrome 19 and began on a different date. Despite considerable effort, we have so far not really understood the mechanism(s) that caused these spikes, why they did not occur in some countries, etc.

According to the first link that @BBlack posted at T141506#2523555 , that faulty Windows update (which caused TLS issues and thereby the spikes, according to the favored theory) rolled out in mid June, which actually seems pretty close to the Tagalog spike reported here (depending on timezones maybe a day too soon for Windows 10, but perhaps matching better for other Windows versions).

Milimetric triaged this task as Normal priority.Sep 19 2016, 3:53 PM
Milimetric removed a project: Pageviews-API.
Milimetric moved this task from Incoming to Backlog (Later) on the Analytics board.
Nuria edited projects, added Analytics-Kanban; removed Analytics.Feb 9 2017, 5:05 PM
Nuria added a comment.EditedMar 27 2017, 7:05 PM

The spike is confined to June 2016 and it is coming from Philiphines, there is a major traffic drop on late March (last week), April and May right before the increase of June 2016, traffic decreases again arround September. This is most apparent on monthly chart:
https://tools.wmflabs.org/siteviews/?platform=all-access&source=pageviews&agent=user&start=2016-03&end=2017-02&sites=tl.wikipedia.org

Increase is present on both desktop and mobile sites and it is tagged as coming from "users". It is mostly present in Chrome but there is a spike from every single browser on the same day. It looks as the spike of traffic is making up for the months prior were traffic was abnormally low.

This is a signal we also see in other wikis (like enwiki) if we just look at traffic from Philiphines. In enwiki spike up is less pronounced but there is definitely a drop.

Elections were going on on Philiphines on May 2016 and looks like there were some hacking incidents on late March 2016 that got reported 1 month later: https://en.wikipedia.org/wiki/2016_in_the_Philippines#cite_note-55

Looks like months from June to September were quite eventful on Philiphines when it comes to political news.

Nuria added a comment.EditedMar 27 2017, 7:06 PM

Traffic coming to tagalog wiki from philiphines

Nuria added a comment.EditedMar 27 2017, 7:17 PM


Traffic coming to enwiki from Philiphines. Same drop spike is present, this spike is not present on traffic overallto enwiki from other countries.

Nuria added a comment.EditedMar 27 2017, 7:51 PM

Spikes due to connection issues like the ones we had with Chrome mentioned earlier in this ticket can be identified by a disproportionate number of requests to the Main_page.

I do not think that is the case here. When spike is happening requests to Main_Page are not disproportionate in comparison to other pageviews.

I looked at pageviews from June 13th to June 19th 2016 coming to enwiki from Philiphines and did the same for data coming to enwiki in September 13th to 19th. I did not filter bot data but bot traffic from PH in enwiki is pretty insignificant.

Select:

use wmf;

select sum(view_count), page_title
from pageview_hourly
where year=2016
and month=06
and day <19
and day >13
and country_code="PH"
and project="en.wikipedia" group by page_title;

I made couple bubble plots that show traffic in each time slot. Note that the plot that shows the spike event has a lower proportion of Main_page views than the plot that show the other two weeks.

Plots only show pages with more than 1000 pageviews.

We cannot know what was going on for certain on spike (and major drop right before) but traffic looks organic

Nuria renamed this task from Much more pageviews in Tagalog Wikipedia since mid-June 2016 to Pageview Spike in Tagalog Wikipedia mid-June 2016.Mar 27 2017, 7:51 PM
Nuria moved this task from Next Up to In Progress on the Analytics-Kanban board.
Nuria updated the task description. (Show Details)
Nuria claimed this task.Mar 29 2017, 12:35 AM
Nuria set the point value for this task to 3.
This comment was removed by Nuria.
Nuria updated the task description. (Show Details)Mar 29 2017, 12:50 AM

Will be closing ticket as I cannot really find anything that might point to a bug, from my brief analysis traffic seems organic.

Nuria moved this task from In Progress to Done on the Analytics-Kanban board.Mar 29 2017, 12:55 AM
Nuria closed this task as Resolved.Mar 29 2017, 7:38 PM