Page MenuHomePhabricator

CN Campaign Setting oddities
Closed, ResolvedPublic1 Story Points

Description

Hey @AndyRussG, here are a couple examples of quirks I've encountered with CN campaign settings in the last week. In the Limit Traffic screenshot, you can see that I get the Limit traffic slider, even though I haven't toggled the Limit traffic option. In the LargeBannerLimitandSwitch screenshot, you can see that none of the sub-options under Legacy hiding... or Impression diet or Large banner limit and switch are showing up.

I am seeing this pretty frequently - the campaign in which I'm working most often right now is C1617_jaJP_dsk_FR. Open and refresh that campaign's settings page and perhaps 1 in 3 times I see something odd with settings.

Details

Related Gerrit Patches:
mediawiki/extensions/CentralNotice : mastercampaignManager: jquery.throttle-debounce dependency

Event Timeline

spatton created this task.Sep 12 2016, 8:15 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 12 2016, 8:15 PM

@spatton I would guess some Javascript isn't loading correctly for you. Do you see any errors in the browser console when it happens?

spatton added a comment.EditedSep 13 2016, 5:48 PM

@Pcoombe et al, you're right; seeing this behavior while updating our C1617_jaJP_mob_FR campaign, and here's the error I have in my console:

load.php:176 Exception in module-execute in module ext.centralNotice.adminUi.campaignManager:
load.php:176 TypeError: $.debounce is not a function TypeError: $.debounce is not a function(…)
log @ load.php:176

Screenshot also attached.

@spatton Thanks for reporting this!!! Certainly worrisome...

Can you tell me your browser, browser version and OS and OS version pls?

Could you pls try this: clear your browser cache and locally stored data (to clear out the RL module cache from LocalStorage) and see if this still happens?

Also, has anyone else run into this?

Thanks!!!

It's not something I've seen at all. (Chrome 52, Mac OS X El Capitan)

Change 311640 had a related patch set uploaded (by AndyRussG):
campaignManager: jquery.throttle-debounce dependency

https://gerrit.wikimedia.org/r/311640

Change 311640 merged by jenkins-bot:
campaignManager: jquery.throttle-debounce dependency

https://gerrit.wikimedia.org/r/311640

Stashbot added a subscriber: Stashbot.

Mentioned in SAL (#wikimedia-operations) [2016-10-20T23:48:39Z] <dereckson@mira> Synchronized php-1.28.0-wmf.22/extensions/CentralNotice: Bump CentralNotice version to fix T145738 and T145447 ([[Gerrit:317077]]) (duration: 00m 54s)

@spatton Hi! We just deployed a fix for this... Is the issue gone? Thanks!!!! :)

Hey @AndyRussG, awesome! It just occurred to me yesterday that I hadn't seen this issue in a couple weeks; I can't reproduce it right now, either. Nice job, I'll let you know if anything weird ever pops up again.

DStrine closed this task as Resolved.Oct 26 2016, 10:29 PM
DStrine set the point value for this task to 1.