Page MenuHomePhabricator

Category display broken
Closed, ResolvedPublic

Description

[Wed Sep 28 10:30:59 2016] [hphp] [8017:7f8a78fff700:104705:000032] [] \nNotice: Undefined property: stdClass::$page_title in /srv/mediawiki/tags/2016-09-28_08:05:49/includes/Title.php on line 451
[Wed Sep 28 10:30:59 2016] [hphp] [8017:7f8a78fff700:104705:000033] [] \nNotice: Undefined property: stdClass::$page_namespace in /srv/mediawiki/tags/2016-09-28_08:05:49/includes/Title.php on line 45

Related Objects

View Standalone Graph
This task is connected to more than 200 other tasks. Only direct parents and subtasks are shown here. Use View Standalone Graph to show more of the graph.
StatusAssignedTask
OpenNone
ResolvedNikerabbit

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 28 2016, 8:32 AM

Happens for example on https://dev.translatewiki.net/wiki/Category:User_sk-2

git bisect does not help, things just start throwing fatal errors (e.g. CirrusSeach).

Trying to find the caller:

[Wed Sep 28 10:49:47 2016] [hphp] [26310:7f75c2fff700:19:000061] [] \nNotice: Undefined property: stdClass::$page_title in /www/dev.translatewiki.net/docroot/w/includes/Title.php on line 454
[Wed Sep 28 10:49:47 2016] [hphp] [26310:7f75c2fff700:19:000062] [] MediaWiki->run/MediaWiki->main/MediaWiki->performRequest/MediaWiki->performAction/ViewAction->show/CategoryPage->view/CategoryPage->closeShowCategory/CategoryViewer->getHTML/CategoryViewer->doCategoryQuery/Title::newFromRow
2016-09-28 08:49:47 translatewiki.net dev_translatewiki_net-bw_: [313f8e91b6646d0ff8eb54ec] /wiki/Category:User_sk-2   ErrorException from line 454 of /www/dev.translatewiki.net/docroot/w/includes/Title.php: PHP Notice: Undefined property: stdClass::$page_namespace
#0 /www/dev.translatewiki.net/docroot/w/includes/Title.php(454): MWExceptionHandler::handleError(integer, string, string, integer, array, array)
#1 /www/dev.translatewiki.net/docroot/w/includes/CategoryViewer.php(355): Title::newFromRow(stdClass)
#2 /www/dev.translatewiki.net/docroot/w/includes/CategoryViewer.php(116): CategoryViewer->doCategoryQuery()
#3 /www/dev.translatewiki.net/docroot/w/includes/page/CategoryPage.php(110): CategoryViewer->getHTML()
#4 /www/dev.translatewiki.net/docroot/w/includes/page/CategoryPage.php(69): CategoryPage->closeShowCategory()
#5 /www/dev.translatewiki.net/docroot/w/includes/actions/ViewAction.php(71): CategoryPage->view()
#6 /www/dev.translatewiki.net/docroot/w/includes/MediaWiki.php(505): ViewAction->show()
#7 /www/dev.translatewiki.net/docroot/w/includes/MediaWiki.php(289): MediaWiki->performAction(CategoryTreeCategoryPage, Title)
#8 /www/dev.translatewiki.net/docroot/w/includes/MediaWiki.php(861): MediaWiki->performRequest()
#9 /www/dev.translatewiki.net/docroot/w/includes/MediaWiki.php(522): MediaWiki->main()
#10 /www/dev.translatewiki.net/docroot/w/index.php(43): MediaWiki->run()
#11 {main}
Nikerabbit triaged this task as Unbreak Now! priority.
Nikerabbit added subscribers: aaron, Legoktm.

By checking out 129839c4c7756f1e9feb84dc698078c7a58cb175 for CirrusSearch and 950cf6016c10953213e5f985dfc18a32d8673197 for core, the error does not happen which leads me to conclude 1885a1ac462c08a3f25e8e8d47205cb18213821b is the cause. It removes page_title and page_namespace which are not included in LinkCache::getSelectFields. Adding people from the patch to CC. In addition of the errors, no pages are displayed in the category.

Restricted Application added subscribers: Jay8g, Luke081515, TerraCodes. · View Herald TranscriptSep 28 2016, 9:01 AM
Nikerabbit renamed this task from PHP notices from Title::newFromRow to Category display broken.Sep 28 2016, 9:01 AM
Nikerabbit added a project: Regression.

Change 313191 had a related patch set uploaded (by Legoktm):
Fix display of categories

https://gerrit.wikimedia.org/r/313191

Change 313191 merged by jenkins-bot:
Fix display of categories

https://gerrit.wikimedia.org/r/313191

Nikerabbit closed this task as Resolved.Sep 28 2016, 9:37 AM
Nikerabbit claimed this task.

Thanks to both of you for resolving this quickly.