Page MenuHomePhabricator

[TUX] Hide "Hide own translations" when nothing to hide
Closed, ResolvedPublic

Description

On a tux=1 type translation page for translatable pages, when you select "proofreading" mode, there is a button saying "show..." or "hide own translations". Clicking it has no visible effect on my system. I am using the newest Firefox version.

Details

Reference
bz48972

Event Timeline

bzimport raised the priority of this task from to Low.Nov 22 2014, 1:42 AM
bzimport set Reference to bz48972.
bzimport added a subscriber: Unknown Object (MLST).

It works for me. I am unable to replicate it.
Can you provide a specific test-case?

kunalgrover05: Thanks for testing this! Could you please describe exact steps how you tested this? URL, plus what you did?

Tested on a local wiki
1- Translate a page to a language.
2- Select review mode
3- 'Hide own translation' hides all my translations
4- Login as a separate user.
5- 'Hide own translation' doesn't hide other user's translations in review mode.

Things I would also test:

  • Make some translations first in different modes of list/page/review
  • Scroll down to see more messages with own messages hidden or shown initially and try toggling the state again.

Purodha: Can you still reproduce this? Which exact Firefox version is this (as "latest" changes every few weeks and depends on your update policy channel)?

If this still happens, could you please open the Error Console (or whatever it is called in your browser) and reload the page that you see the problem on?
If there is a problem or an error with JavaScript it should be printed in that console.
For more information: https://developer.mozilla.org/en-US/docs/Tools/Web_Console

I'm unable to reproduce. Please note that the default view (unreviewed) of review mode does not include your own translations in the first place, so there is nothing to show hide.

To make this behavior clearer, the button should be hidden when there are nothing to hide. I updated the summary to match that.

Nemo_bis claimed this task.May 23 2015, 5:36 PM

I'll try to do this. We only need to hide the button in proofread + unreviewed mode.

Change 213248 had a related patch set uploaded (by Nemo bis):
Don't offer to hide own translations when already hidden in proofread mode

https://gerrit.wikimedia.org/r/213248

Nemo_bis set Security to None.
Qgil added a subscriber: Qgil.Jun 4 2015, 10:43 AM

We are trying to help all open tasks listed under "Work continues after Lyon" at the Wikimedia Hackathon 2015 workboard finding their best way forward. * If you are participating in Wikimania, consider adding the #Wikimania-Hackathon-2015 project to get this task in that loop, which is about to start. * If you think this project could welcome help from a dedicated Google Summer of Code or Outreachy intern, or from an Individual Engagement Grant, add the Possible-Tech-Projects project. * If you would like to receive some other type of support (organizing a Tech Talk, establishing contacts with existing developer teams in Wikimedia or elsewhere, travel sponsorship for a related activity... you name it), please create a subtask explaining your request and associate it with Developer-Advocacy (or you can start by commenting here if you prefer). * Keeping the description, priority and assigned fields up to date always helps. :) For some context about this message, see T101151: Evaluate which projects showcased at the Wikimedia Hackathon should be supported further. It is the last communication related to Wikimedia-Hackathon-2015 that we will post here.

Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptAug 11 2016, 9:02 AM
Nikerabbit updated the task description. (Show Details)Aug 31 2016, 5:42 AM
Nikerabbit removed a subscriber: wikibugs-l-list.

I am waiting on review of https://gerrit.wikimedia.org/r/304828 so that this patch is easier to make work properly.

Qgil removed a subscriber: Qgil.Aug 31 2016, 9:27 AM

This is a relatively small task from the Translate backlog.

Change 213248 merged by jenkins-bot:
Don't offer to hide own translations when already hidden in proofread mode

https://gerrit.wikimedia.org/r/213248

Nikerabbit added a subscriber: Amire80.

I tried to deploy this to translatewiki.net, but due to T146873 I had to rollback. @Amire80 You can test this on dev.translatewiki.net if you don't want to wait for that bug to be resolved.

Amire80 moved this task from QA to Done on the Language-Q1-2016-17 Sprint 6 board.Sep 28 2016, 3:17 PM
Amire80 closed this task as Resolved.Oct 3 2016, 9:46 AM