Page MenuHomePhabricator

Disable magic link functionality by default in MediaWiki
Closed, ResolvedPublic

Description

  • Set default in Wikimedia config to be true
  • Ensure RFC and PMID are in the interwiki map
  • Set default in MediaWiki core to be false

Details

Related Gerrit Patches:

Event Timeline

Legoktm created this task.Oct 6 2016, 1:04 AM
Restricted Application added subscribers: JEumerus, Matanya, Aklapper. · View Herald TranscriptOct 6 2016, 1:04 AM
JJMC89 added a subscriber: JJMC89.Oct 6 2016, 1:07 AM

Change 314463 had a related patch set uploaded (by Legoktm):
Enable magic links regardless of MediaWiki core default

https://gerrit.wikimedia.org/r/314463

Change 314474 had a related patch set uploaded (by Legoktm):
Add 'pmid' to the default interwiki list, and update 'rfc'

https://gerrit.wikimedia.org/r/314474

PMID has been proposed for addition to the Wikimedia interwiki map https://meta.wikimedia.org/wiki/Talk:Interwiki_map#PMID

Dereckson added a subscriber: Dereckson.

The English Wikipedia seems to use PMID magic links currently.

https://en.wikipedia.org/wiki/Wikipedia:PMID

Change 314474 merged by jenkins-bot:
Add 'pmid' to the default interwiki list, and update 'rfc'

https://gerrit.wikimedia.org/r/314474

Huji added a subscriber: Huji.EditedOct 11 2016, 1:23 PM

@Legoktm ever since 314474 has been merged, I get error messages when running the update script stating that the iw_api value does not have a default. I fixed it by temporarily passing a default value, and I see from DB schema that it does have a default of NULL. Thought I should report it anyway.

Change 314463 merged by jenkins-bot:
Enable magic links regardless of MediaWiki core default

https://gerrit.wikimedia.org/r/314463

Legoktm updated the task description. (Show Details)Oct 15 2016, 6:35 AM

Change 316080 had a related patch set uploaded (by Legoktm):
addRFCandPMIDInterwiki: Fix strict mode errors

https://gerrit.wikimedia.org/r/316080

@Legoktm ever since 314474 has been merged, I get error messages when running the update script stating that the iw_api value does not have a default. I fixed it by temporarily passing a default value, and I see from DB schema that it does have a default of NULL. Thought I should report it anyway.

Thanks, after enabling MySQL strict mode I can reproduce. I submitted a patch for it.

Change 316080 merged by jenkins-bot:
addRFCandPMIDInterwiki: Fix strict mode errors

https://gerrit.wikimedia.org/r/316080

Change 319633 had a related patch set uploaded (by Legoktm):
Disable magic links by default

https://gerrit.wikimedia.org/r/319633

Change 319633 merged by jenkins-bot:
Disable magic links by default

https://gerrit.wikimedia.org/r/319633

Change 319784 had a related patch set uploaded (by Legoktm):
Disable magic links by default

https://gerrit.wikimedia.org/r/319784

Legoktm closed this task as Resolved.Nov 4 2016, 3:46 AM

Change 319784 merged by jenkins-bot:
Disable magic links by default

https://gerrit.wikimedia.org/r/319784