Page MenuHomePhabricator

undefined method LBFactoryMulti::destroyInstance() when running extensions/CirrusSearch/maintenance/updateSearchIndexConfig.php
Closed, ResolvedPublic

Description

When running extensions/CirrusSearch/maintenance/updateSearchIndexConfig.php I get:

Fatal error: Call to undefined method LBFactoryMulti::destroyInstance() in /srv/mediawiki/php-1.28.0-wmf.21/includes/ForkController.php on line 153

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 11 2016, 7:00 PM
Smalyshev triaged this task as Unbreak Now! priority.Oct 11 2016, 7:00 PM
Smalyshev added a subscriber: aaron.
Restricted Application added subscribers: Jay8g, Luke081515, TerraCodes. · View Herald TranscriptOct 11 2016, 7:00 PM

There's no destroyInstance in any LB* classes indeed. Seems to be caused by commit 1162ed5f88e5a77ea6feed971813914a95004b4f - looks like revert wasn't complete.

Ping @Catrope.

Smalyshev removed aaron as the assignee of this task.Oct 11 2016, 7:06 PM
Smalyshev added a subscriber: daniel.

Change 315328 had a related patch set uploaded (by Smalyshev):
Call destroy method that actually exists instead of one that doesn't anymore.

https://gerrit.wikimedia.org/r/315328

Change 315332 had a related patch set uploaded (by Smalyshev):
Call destroy method that actually exists instead of one that doesn't anymore.

https://gerrit.wikimedia.org/r/315332

Change 315328 merged by jenkins-bot:
Call destroy method that actually exists instead of one that doesn't anymore.

https://gerrit.wikimedia.org/r/315328

Change 315332 merged by jenkins-bot:
Call destroy method that actually exists instead of one that doesn't anymore.

https://gerrit.wikimedia.org/r/315332

Mentioned in SAL (#wikimedia-operations) [2016-10-11T23:54:47Z] <ebernhardson@mira> Synchronized php-1.28.0-wmf.22/includes/ForkController.php: SWAT T147881 Call destroy method that actually exists instead of one that doesnt anymore. (duration: 00m 52s)

EBernhardson closed this task as Resolved.Oct 12 2016, 12:10 AM
EBernhardson claimed this task.

merged to master, cherry-picked and deployed to wmf.22