Page MenuHomePhabricator

[betalabs-regression] Flow board - switching to VE produces "TypeError: this.parseHtml is not a function"
Closed, ResolvedPublic0 Story Points

Description

  1. On a Flow board in betalabs, open any entry for editing and switch to VE.
  2. The switching to VE never ends - the following error is displayed in the Console:

load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=1u1uxh5:176 TypeError: this.parseHtml is not a function

  1. The same error is displayed everywhere where the switch to VE is available.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 21 2016, 7:35 PM

Caused by rEVEDe1a887ccf857: Migrate DesktopWikitextArticleTarget code upstream which renamed ve.init.mw.Target#parseHtml without adding a [BREAKING CHANGE] tag or grepping for callers.

Change 322948 had a related patch set uploaded (by Catrope):
Adjust to breaking change Icca471541173 in VisualEditor

https://gerrit.wikimedia.org/r/322948

Jdforrester-WMF added a project: VisualEditor.
Jdforrester-WMF set the point value for this task to 0.
Jdforrester-WMF moved this task from To Triage to TR0: Interrupt on the VisualEditor board.

Change 322948 merged by jenkins-bot:
Adjust to breaking change Icca471541173 in VisualEditor

https://gerrit.wikimedia.org/r/322948

Jdforrester-WMF triaged this task as Unbreak Now! priority.Nov 22 2016, 8:04 PM
Jdforrester-WMF removed a project: Patch-For-Review.
Restricted Application added subscribers: Jay8g, Luke081515, TerraCodes. · View Herald TranscriptNov 22 2016, 8:04 PM
Etonkovidova added a comment.EditedNov 24 2016, 1:30 AM

Checked the fix in betalabs and in production 1.29.0-wmf.4

Jdforrester-WMF closed this task as Resolved.Nov 29 2016, 1:02 AM