Page MenuHomePhabricator

Metro Mad Linea 7.png file half-disappeared - it can't be used
Closed, ResolvedPublic

Description

Hi,
https://commons.wikimedia.org/wiki/File:Metro_Mad_Linea_7.png isn't available to use and breaks articles where it is used. Please fix it.

Thanks,
Martin Urbanec
https://cs.wikipedia.org/wiki/Wikipedista:Martin_Urbanec

Event Timeline

Restricted Application added a project: User-Urbanecm. · View Herald TranscriptDec 17 2016, 11:23 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Urbanecm triaged this task as High priority.Dec 17 2016, 11:24 AM
Urbanecm added a subscriber: Revent.

Accessing the original file returns a 404 error.

Poyekhali moved this task from Untriaged to Triaged on the Multimedia board.Dec 17 2016, 12:18 PM
Poyekhali moved this task from Incoming to Thumbnail and file renderings on the Commons board.

I know. I meant why it return 404.

Urbanecm moved this task from Backlog to Watching on the User-Urbanecm board.Dec 17 2016, 1:14 PM

Well, it looks gone. The file was uploaded in 2012, apparently still existed around a year ago: http://wayback.archive.org/web/20151001170542/https://es.wikipedia.org/wiki/Línea_7_(Metro_de_Madrid)#Recorrido

I guess you could reupload the 800px thumbnail, copied from the Wayback Machine page:

The files of course shouldn't be disappearing, but this isn't really my area of experience. Perhaps @aaron or @fgiunchedi can help. But from what I've seen of previous similar cases (this occurs regularly), it's probably gone for good.

Tgr added a subscriber: Tgr.Dec 18 2016, 12:25 AM

Yay for mirrors! http://ftpmirror.your.org/pub/wikimedia/images/wikipedia/commons/c/cf/Metro_Mad_Linea_7.png

As far as I can see, nothing happened to the file since 2012. Files occasionally get lost on rename or delete, and that is bad, but losing them with no apparent reason is even more scary.

Tgr added a comment.Dec 18 2016, 12:52 AM

Apparently if the file had been uploaded a year later, we would be out of luck: T53001: Image tarball dumps on your.org are not being generated

Filed T153565: MediaWiki file operations are fragile, causing occasional data loss about what I think is the more fundamental issue (apart from the lack of reliable mirrors).

Uploaded; thanks for finding out the mirror. I guess this task can be resolved now? Further work would be in T53001 & T153565.

Urbanecm closed this task as Resolved.Dec 18 2016, 11:01 AM
Urbanecm assigned this task to zhuyifei1999.

Thanks for resolving, seems it works, marking as resolved.