Remove Flow from the user talk namespace on Persian Wikipedia
Closed, ResolvedPublic

Description

The community has decided to remove Flow from the user talk namespace but keep it on two community spaces (ویکی‌پدیا:قهوه‌خانه/خبررسانی and ویکی‌پدیا:درخواست راهنمایی).

I'm following up with them about how to archive the pages.

Just curious, have they identified specific problems for the removal of User Talk pages?

As a person who voted to keep flow user pages (and my user talk page is flow) i can see why they are opposing. The biggest reason mentioned by them is notification. My talk page had around 200 watchers and they were getting notification every time edits my page. Which can be quite a noise given it's very active page. Number of watchers is now around 170 (which is still shocking)
The other part mentioned is not ability to search. Having really hard time to use history, and being impossible to see a suppressed (or deleted) conversation without making it public. These are all of feedbacks I've got from the community.

Thank you for your feedback. It is close to what we have collected on the survey about Flow.

I don't understand the part of notifications. People watching your page would also be notified before being converted to Flow, right? In fact, with Flow they are notified only with new threads, while in traditional wikitext they get notified for any changes. I m not trying to argue! Only to understand. Thank you.

I don't understand the part of notifications. People watching your page would also be notified before being converted to Flow, right? In fact, with Flow they are notified only with new threads, while in traditional wikitext they get notified for any changes. I m not trying to argue! Only to understand. Thank you.

As I said, I'm in favor of keeping flow. Bugs can be fixed. Anyway, by notification I mean Echo notification if anyone makes a topic in my talk page. In wikitext mode, people see the change in Special:Watchlist but they don't get echo notification.

I don't understand the part of notifications. People watching your page would also be notified before being converted to Flow, right? In fact, with Flow they are notified only with new threads, while in traditional wikitext they get notified for any changes. I m not trying to argue! Only to understand. Thank you.

There is two different things concerning notifications: Notifications (as a tool, formerly Echo) and watchlist notifications. For the following, I'm assuming you have default settings.

With Flow, you have a Notification (blue badge) when a topic is created on a page you watch, plus a line in your watchlist.
With unstructured wikitext discussion pages, you have a line in your watchlist for every change.

I think the Notifications can be perceived as noise, depending on the wiki (as a comparison, my volunteer page, using Flow, has 256 watchers).

Thus, with that feedback, the Collaboration team has added that Notifications issue to their short list.

As I said, I'm in favor of keeping flow. Bugs can be fixed.

There is still some communities that have help pages using Flow. Users will see if changes happen and may reconsider.

There is still some communities that have help pages using Flow. Users will see if changes happen and may reconsider.

I think there is a misunderstanding here. As a developer here, I'm definitely in favor of removing flow boards because that's the community wants. But as a member of that community, I was a favor of keeping it.

There is still some communities that have help pages using Flow. Users will see if changes happen and may reconsider.

I think there is a misunderstanding here. As a developer here, I'm definitely in favor of removing flow boards because that's the community wants. But as a member of that community, I was a favor of keeping it.

I've understood what you were meaning. I was just trying to reassure you about a possible change from your community: in the future, if changes are made in Flow, they may reconsider that decision! :)

Trizek-WMF closed this task as Resolved.Feb 10 2017, 1:05 PM

All boards on user talk pages have been archived.

Note: one user apparently refuses the community decision.

As a person who voted to keep flow user pages (and my user talk page is flow) i can see why they are opposing. The biggest reason mentioned by them is notification. My talk page had around 200 watchers and they were getting notification every time edits my page.

This is T138204: Find a way to avoid Notifications spam when a new topic is created on a Flow page you watch. See also T100528: Improve organization and control for Flow notifications (tracking + ideas), a more general solution (particularly F169936).

and being impossible to see a suppressed (or deleted) conversation without making it public.

I can not reproduce this at all. It works as I would expect.

If a topic or post is deleted or suppressed, users with the appropriate permissions can view it without changing the visibility. For topics, you use the standard URL (either from a bookmark/link or via the page history). For posts, you access the post via the page history, using the "comment" link ("deleted a comment", "suppressed a comment", etc.). Can you pass this feedback back to Persian Wikipedia? I am wondering if the UI needs to be improved, or there was a misunderstanding.

"appropriate permissions" means the same required to put it in that state. (Users that can delete topics can view deleted topics, users that can suppress topics can view suppressed topics.)

I will check and come back to you.