Page MenuHomePhabricator

Fix notification of users when nominating an article for deletion through the Page Curation Tool
Closed, ResolvedPublic

Description

Currently the Page Curation Tool locks up when it tries to notify users of that articles they have created have been nominated for deletion.

This bug should be treated as a high priority because there is a strong community consensus on enwiki that creators should be notified when their articles are nominated for deletion. The fact that the Page Curation Tool is not doing this means that responsible editors have no choice but to not use a core part of its functionality (in favour of Twinkle).

See https://en.wikipedia.org/wiki/Wikipedia_talk:New_pages_patrol/Reviewers#Page_Curation_Tool_still_not_notifying_users

Event Timeline

joeroe created this task.Feb 2 2017, 4:36 PM
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptFeb 2 2017, 4:36 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
joeroe added a comment.Feb 2 2017, 4:49 PM

Steps to reproduce (courtesy of Jbhunley in the linked enwiki discussion above):

Simply tagging an article with any CSD tag puts the Tool in its waiting loop, the longest I have let it run is about five minutes, it never exits and you must refresh the page. When you refresh the window the CSD tag is applied but there is no notification placed on the page author's talk page. This happens whether there is a talk page there or if it is a red link. I am using Chrome on an iPadPro IOS v10.2.1 and accessing the Desktop version of the site. I have also had this problem using Chrome on Windows 10 but I have not tried it recently.

kaldari added a subscriber: kaldari.Feb 2 2017, 5:52 PM

It's throwing the following JavaScript error:

TypeError: s is undefined

which is coming from mw.html.escape(). It looks like something is trying to escape some text that doesn't exist.

kaldari triaged this task as High priority.Feb 2 2017, 5:53 PM

Marking high priority since this is actually broken currently.

I also created this as Task T157067 without seeing this had already been created. Feel free to merge the two.

Mattflaschen-WMF raised the priority of this task from High to Unbreak Now!.
Restricted Application added subscribers: Jay8g, TerraCodes. · View Herald TranscriptFeb 2 2017, 9:22 PM

Sorry, this is a regression introduced by my earlier commit, rEPTR891b3b6b5109: Add MessagePoster/Flow support to PageTriage, fix related issues (which arrived shortly after https://en.wikipedia.org/w/index.php?title=MediaWiki:PageTriageExternalDeletionTagsOptions.js&diff=next&oldid=506788360).

To fix, please copy https://en.wikipedia.org/wiki/User:Mattflaschen-WMF/MediaWiki:PageTriageExternalDeletionTagsOptions.js to https://en.wikipedia.org/wiki/MediaWiki:PageTriageExternalDeletionTagsOptions.js .

talkpagenotiftopictitle also needs to be added for any future speedy deletion tags (note, there are 3 topic titles for deletion (though more can be added), it just happens these are all speedy deletion).

@Etonkovidova Please wait until it is copied to QA.

I fixed it on enwiki and testwiki. @Mattflaschen-WMF: Can you update the documentation at https://www.mediawiki.org/wiki/Extension:PageTriage#On-wiki_configuration? Thanks!

Etonkovidova added a comment.EditedFeb 6 2017, 10:30 PM

QA recommendation: Resolve.

jmatazzoni closed this task as Resolved.Feb 17 2017, 7:31 PM