Page MenuHomePhabricator

No thumbnail for previous file version (Commons)
Closed, ResolvedPublic

Description

https://commons.wikimedia.org/wiki/File:Them_Ex-Fire_Power_2.jpg

This is not a singular case. Browsing lots of old files, in past I encountered the same problem on other files as well.

Update: one more example https://commons.wikimedia.org/wiki/File:Alexandre_Legna.jpg

Event Timeline

XXN created this task.Feb 18 2017, 6:06 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 18 2017, 6:06 PM
XXN updated the task description. (Show Details)Feb 18 2017, 6:08 PM
matmarex added a subscriber: matmarex.

That version appears to be completely missing, actually. Note how the date is not a link to view that version, and the "revert" link displays an error when clicked.

Looking at the page history, the file only seems to have been uploaded once, but the upload log has two entries. Something is clearly bogus here, but I'm not sure if the file revision has disappeared or if the log entry was incorrectly duplicated. I'll note also that UploadWizard is not supposed to allow uploading new versions of existing files.

XXN updated the task description. (Show Details)Apr 15 2017, 3:09 PM
XXN added a comment.EditedApr 15 2017, 3:18 PM

added one more example for reference -> https://commons.wikimedia.org/wiki/File:Alexandre_Legna.jpg. But this a slightly different case. If for the originally reported case the upload log displays identical file sizes for 'both' versions: 345 × 500 (33 KB), for this file seems that there were really two different files, according to the upload log displayed in page:
641 × 960 (60 KB) and 720 × 480 (52 KB)

So, not just a duplicated entry?

XXN updated the task description. (Show Details)Apr 15 2017, 3:22 PM
matmarex removed a subscriber: matmarex.May 29 2017, 5:24 PM
dr0ptp4kt triaged this task as Normal priority.Aug 7 2017, 4:35 PM
dr0ptp4kt moved this task from Untriaged to Next up on the Multimedia board.
dr0ptp4kt added a subscriber: dr0ptp4kt.

Next action would be to conduct technical root cause analysis, then further scope for potential bugfix.

matthiasmullie moved this task from Next up to Doing on the Multimedia board.
MBinder_WMF moved this task from Doing to Next up on the Multimedia board.Sep 15 2017, 4:03 PM

Change 378702 had a related patch set uploaded (by Matthias Mullie; owner: Matthias Mullie):
[mediawiki/core@master] Block same-file reuploads

https://gerrit.wikimedia.org/r/378702

This looks a lot like a race condition.
For both files mentioned, there are 2 logging entries (one of type upload, one overwrite, both with the exact same timestamp), but the overwrite one doesn't have log_page associated with the correct page (it's 0)
It does look like, for both files, the 2 revisions were in fact different images (Them_Ex-Fire_Power_2.jpg revs have the same dimensions, but a different hash)

I couldn't find any recent occurrences of this exact problem, so it looks like this has been solved by now.

However, I did find similar issues where the exact same file was uploaded twice at exactly the same time (creating the same kind of log entries as well)
That's not as big an issue (the files are not lost), but it creates a messy history...

Change 378702 merged by jenkins-bot:
[mediawiki/core@master] Block same-file reuploads

https://gerrit.wikimedia.org/r/378702

matthiasmullie closed this task as Resolved.Sep 27 2017, 8:01 AM

Whoops - shouldn't have closed; hasn't been QA'd yet!

matthiasmullie reopened this task as Open.Sep 27 2017, 8:06 AM
ABorbaWMF closed this task as Resolved.Nov 3 2017, 10:35 PM
ABorbaWMF added a subscriber: ABorbaWMF.

Appears to be fixed on beta commons: