Page MenuHomePhabricator

Align the column texts perfectly
Closed, ResolvedPublic

Description

Motivation
When I try to resolve an edit conflict, I want to quickly scan through the columns. If the texts are perfectly aligned I can easily scan through the lines.

Task
Make sure that the width of the text lines is exactly the same for both columns. This means:

  • If the text is in one of the changes boxes, and thus preceded by a vertical line, it still does not have a smaller length,but exactly the same as the editor
  • If the text is not in one of the changes boxes, it is also exactly as long as in the editor, even if that means that the text column on the left has slightly different widths for separate lines

Also make sure the spacing between the lines is the same between editor and text column, at least for the most used browser type with no special settings (which is chrome according to the WMF)

Example

Event Timeline

WMDE-Fisch moved this task from Proposed to Todo on the WMDE-QWERTY-Team board.Apr 11 2017, 3:46 PM
Lea_WMDE updated the task description. (Show Details)Apr 12 2017, 2:31 PM
WMDE-Fisch moved this task from Todo to Sprint ready on the WMDE-QWERTY-Team board.

Change 348707 had a related patch set uploaded (by WMDE-Fisch):
[mediawiki/extensions/TwoColConflict@master] Adjust padding of text content blocks

https://gerrit.wikimedia.org/r/348707

The above patch fixes the issue in the screenshot. During the meeting I also mentioned other issues that where related to OS/Browser text layouting defaults. I could not reproduce these errors, neither on IE/FF/Chrome. So if there are no other reports of misaligned text I would say the issue is fixed when the patch is merged and you confirm it.

Change 348707 merged by jenkins-bot:
[mediawiki/extensions/TwoColConflict@master] Adjust padding of text content blocks

https://gerrit.wikimedia.org/r/348707

Addshore closed this task as Resolved.May 11 2017, 8:51 AM
Tobi_WMDE_SW moved this task from Done to Demoed on the WMDE-QWERTY-Team board.Jun 6 2017, 3:12 PM