Page MenuHomePhabricator

Request to change namespaces of zh-classical.wikipedia
Closed, ResolvedPublic

Description

Add abbrs:

WP: -> 維基大典:
H: -> Help:
WT: -> Wikipedia talk:
T: -> Template:
CAT: -> Category:
P: -> 門:

Fix namespaces:
Wikipedia talk: -> 維基大典討論:
Portal: -> 門:
Portal talk: -> 議:

Event Timeline

LNDDYL created this task.Apr 9 2017, 3:40 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 9 2017, 3:40 PM
LNDDYL renamed this task from 請求給文言維基大典(zh-classical.wikipedia)加入縮寫別名(alias) to 請求給文言維基大典(zh-classical.wikipedia)加入命名空間(namespace)的縮寫別名(alias) .Apr 9 2017, 3:45 PM
vjudge404 added a subscriber: vjudge404.EditedApr 9 2017, 3:58 PM

Please wait for a week for discussing before taking any further actions.

Shangkuanlc renamed this task from 請求給文言維基大典(zh-classical.wikipedia)加入命名空間(namespace)的縮寫別名(alias) to Request to provide zh-classical.wikipedia abbreviation alias of namespace / 請求給文言維基大典(zh-classical.wikipedia)加入命名空間(namespace)的縮寫別名(alias) .Apr 9 2017, 4:03 PM
Shangkuanlc added a subscriber: Shangkuanlc.
LNDDYL renamed this task from Request to provide zh-classical.wikipedia abbreviation alias of namespace / 請求給文言維基大典(zh-classical.wikipedia)加入命名空間(namespace)的縮寫別名(alias) to Request to provide zh-classical.wikipedia abbreviation alias of namespace / 請求給文言維基大典加入命名空間的縮寫別名 .Apr 9 2017, 4:07 PM
LNDDYL updated the task description. (Show Details)Apr 9 2017, 4:18 PM
Urbanecm moved this task from Unsorted to Single wikis on the Community-consensus-needed board.
Urbanecm triaged this task as Low priority.
LNDDYL updated the task description. (Show Details)Apr 15 2017, 9:41 AM
This comment was removed by vjudge404.
vjudge404 renamed this task from Request to provide zh-classical.wikipedia abbreviation alias of namespace / 請求給文言維基大典加入命名空間的縮寫別名 to Request to change namespaces of zh-classical.wikipedia.Apr 15 2017, 9:50 AM
vjudge404 updated the task description. (Show Details)
LNDDYL updated the task description. (Show Details)Apr 15 2017, 10:25 AM
vjudge404 added a comment.EditedApr 16 2017, 5:54 AM

A week passed and the community has agreed with this (discussion ).

Dargasea added a subscriber: Dargasea.EditedApr 16 2017, 5:56 AM

^ after a week of discussion starting 9 Apr: 5 {{support}}, no other opinion.

edit: Double post, apologies.

Urbanecm claimed this task.Apr 24 2017, 6:36 AM

Change 349889 had a related patch set uploaded (by Urbanecm):
[operations/mediawiki-config@master] Add NS aliases for zh_classicalwiki

https://gerrit.wikimedia.org/r/349889

What's wrong with the namespaces we should fix? Can you tell what is wrong exatly and how we can reproduce the issue?

vjudge404 added a comment.EditedApr 24 2017, 9:11 AM
  1. "Wikipedia talk:" should changed to "NS_PROJECT_TALK"
  2. "門" (100) and "議" (101) only have Chinese names. We want to add English aliases: Portal -> 門, Portal talk -> 議.

I'm sorry I didn't express my ideas clearly.

Change 349889 merged by jenkins-bot:
[operations/mediawiki-config@master] Add NS aliases for zh_classicalwiki

https://gerrit.wikimedia.org/r/349889

hashar added a subscriber: hashar.Apr 25 2017, 1:14 PM

For the record

$ mwscript namespaceDupes.php --wiki=zh_classicalwiki --fix
0 pages to fix, 0 were resolvable.

pagelinks from=14448 ns=0 dbk=WP:5P -> 維基大典:5P
pagelinks from=74580 ns=0 dbk=WP:COCHRANE -> 維基大典:COCHRANE
pagelinks from=2837 ns=0 dbk=WP:EA -> 維基大典:EA
pagelinks from=2844 ns=0 dbk=WP:EA -> 維基大典:EA
pagelinks from=68426 ns=0 dbk=WP:FRIENDLY -> 維基大典:FRIENDLY
pagelinks from=78 ns=0 dbk=WP:VP -> 維基大典:VP
pagelinks from=725 ns=0 dbk=WP:VP -> 維基大典:VP
pagelinks from=77893 ns=0 dbk=Wp:Subst -> 維基大典:Subst
pagelinks from=76066 ns=0 dbk=H:FN -> 幫助:FN
pagelinks from=76070 ns=0 dbk=H:FN -> 幫助:FN
pagelinks from=76071 ns=0 dbk=H:FN -> 幫助:FN
pagelinks from=76072 ns=0 dbk=H:FN -> 幫助:FN
pagelinks from=76073 ns=0 dbk=H:FN -> 幫助:FN
13 links to fix, 13 were resolvable.

Looks good!
vjudge404 added a comment.EditedApr 25 2017, 1:16 PM
  1. "Wikipedia talk:" should changed to "NS_PROJECT_TALK"
  2. "門" (100) and "議" (101) only have Chinese names. We want to add English aliases: Portal -> 門, Portal talk -> 議.

    I'm sorry I didn't express my ideas clearly.

It's also a part of the request but hasn't been solved yet.

Mentioned in SAL (#wikimedia-operations) [2017-04-25T13:16:54Z] <hashar@naos> Synchronized wmf-config/InitialiseSettings.php: Add NS aliases for zh_classicalwiki - T162547 (duration: 01m 00s)

Change 350198 had a related patch set uploaded (by Urbanecm):
[operations/mediawiki-config@master] Fix namespace Wikipedia_talk for zh_classicalwiki

https://gerrit.wikimedia.org/r/350198

Change 350199 had a related patch set uploaded (by Urbanecm):
[operations/mediawiki-config@master] Two namespace aliases for zh_classicalwiki

https://gerrit.wikimedia.org/r/350199

Thanks a lot!

Change 350199 merged by jenkins-bot:
[operations/mediawiki-config@master] Two namespace aliases for zh_classicalwiki

https://gerrit.wikimedia.org/r/350199

For the record:

$ mwscript namespaceDupes.php --wiki=zh_classicalwiki --fix
0 pages to fix, 0 were resolvable.

pagelinks from=7854 ns=0 dbk=Portal:Halbleiter -> 門:Halbleiter
pagelinks from=37 ns=0 dbk=Portal:Punk -> 門:Punk
pagelinks from=281 ns=0 dbk=Portal:Punk -> 門:Punk
pagelinks from=15707 ns=0 dbk=Portal:Punk -> 門:Punk
pagelinks from=66664 ns=0 dbk=Portal:三國/史 -> 門:三國/史
pagelinks from=12576 ns=0 dbk=Portal:三國/戰役年表 -> 門:三國/戰役年表
pagelinks from=78 ns=0 dbk=Portal:主題首頁 -> 門:主題首頁
pagelinks from=7969 ns=0 dbk=Portal:史學 -> 門:史學
pagelinks from=299 ns=0 dbk=Portal:幾何 -> 門:幾何
pagelinks from=78 ns=0 dbk=Portal:數學 -> 門:數學
pagelinks from=212 ns=0 dbk=Portal:數學 -> 門:數學
pagelinks from=78 ns=0 dbk=Portal:格致 -> 門:格致
pagelinks from=72128 ns=0 dbk=Portal:首頁 -> 門:首頁
13 links to fix, 13 were resolvable.

Looks good!

You're welcome!

Mentioned in SAL (#wikimedia-operations) [2017-04-25T13:24:39Z] <hashar@naos> Synchronized wmf-config/InitialiseSettings.php: Two namespace aliases for zh_classicalwiki - T162547 (duration: 00m 49s)

Change 350198 merged by jenkins-bot:
[operations/mediawiki-config@master] Fix namespace Wikipedia_talk for zh_classicalwiki

https://gerrit.wikimedia.org/r/350198

Mentioned in SAL (#wikimedia-operations) [2017-04-25T13:31:49Z] <hashar@naos> Synchronized wmf-config/InitialiseSettings.php: Fix namespace Wikipedia_talk for zh_classicalwiki - T162547 (duration: 00m 48s)

Urbanecm closed this task as Resolved.Apr 25 2017, 1:34 PM