Page MenuHomePhabricator

Deploy ORES review tool on French Wikipedia
Closed, ResolvedPublic

Description

French Wikipedia has finished the Labelling work.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 11 2017, 2:19 PM
Halfak triaged this task as Normal priority.May 11 2017, 2:31 PM
Halfak moved this task from Untriaged to New development on the Scoring-platform-team board.
Restricted Application added a project: artificial-intelligence. · View Herald TranscriptJun 5 2017, 5:07 PM

Change 357328 had a related patch set uploaded (by Ladsgroup; owner: amir):
[operations/mediawiki-config@master] Enable ORES review tool in frwiki

https://gerrit.wikimedia.org/r/357328

Restricted Application added a project: User-Ladsgroup. · View Herald TranscriptJun 5 2017, 11:16 PM

Change 357328 merged by jenkins-bot:
[operations/mediawiki-config@master] Enable ORES review tool in frwiki

https://gerrit.wikimedia.org/r/357328

Mentioned in SAL (#wikimedia-operations) [2017-06-05T23:23:26Z] <thcipriani> frwiki create tables ores_model and ores_classification T165044

Mentioned in SAL (#wikimedia-operations) [2017-06-05T23:32:25Z] <thcipriani@tin> Synchronized wmf-config/InitialiseSettings.php: SWAT: [[gerrit:357328|Enable ORES review tool in frwiki]] T165044 (duration: 00m 40s)

Ladsgroup moved this task from Incoming to Done on the User-Ladsgroup board.Jun 5 2017, 11:58 PM

Has an announcement been made? If not, maybe @Trizek can help us out. :)

Trizek added a comment.Jun 6 2017, 4:51 PM

Has an announcement been made? If not, maybe @Trizek can help us out. :)

The difficulty on this project is to know which step is the next. :)

People are expecting to have ORES predictions in the RecentChanges. What have to be done to have it?

Option 1: Enable the new filters "Nouveaux filtres pour la révision des modifications" beta feature and find the filters in the list.

Option 2: ORES should just work anyway by highlighting items in the recent changes, but it looks like that is broken. I see "r
Cette modification pourrait avoir des problèmes et devrait être revue (plus d'information)" in the Legend, but no highlighting even when setting &hidenondamaging=1. So it looks like maybe another ORES Review Tool regression.

Ping @jmatazzoni. Should we expect ORES' basic functionality to still work without enabling the new filters?

Trizek added a comment.Jun 6 2017, 5:26 PM

So it is done. Cool, it is working.

I would have been nice to have a notice before you enable it, just to keep communities aware of this change (and also help the poor community liaison to know he may face questions). :)

Trizek removed a subscriber: Trizek.Jun 6 2017, 5:31 PM
Halfak added a comment.Jun 6 2017, 5:56 PM

@Trizek-WMF, fair point. We'd made announcements via our own channels, but I can see why post on frwiki ahead of time would have been better. What would have been a better way for you to know that this was coming? Maybe we should keep you subscribed to the relevant sub-tasks so you can see this kind of thing coming?

Option 1: Enable the new filters "Nouveaux filtres pour la révision des modifications" beta feature and find the filters in the list.
Option 2: ORES should just work anyway by highlighting items in the recent changes, but it looks like that is broken. I see "r
Cette modification pourrait avoir des problèmes et devrait être revue (plus d'information)" in the Legend, but no highlighting even when setting &hidenondamaging=1. So it looks like maybe another ORES Review Tool regression.
Ping @jmatazzoni. Should we expect ORES' basic functionality to still work without enabling the new filters?

Some of that stuff is behind preferences now, at least on the RC page, and there's a script to migrate people who had the ORES beta feature enabled to the new preferences. On frwiki that's a non-issue, because it never had the ORES beta feature.

The preference you're looking for is called Met en surbrillance à l'aide de couleurs les modifications qui semblent problématiques et ajoute un « r » pour signifier « nécessite une relecture » (pour définir le niveau auquel sont marquées les modifications, utiliser le paramètre « Seuil de prédiction » dans les préférences de la liste de suivi) in the Modifications récentes section, and is only visible if the Nouveau filtres pour la révision des modifications beta feature is not enabled.

@Trizek-WMF, fair point. We'd made announcements via our own channels, but I can see why post on frwiki ahead of time would have been better. What would have been a better way for you to know that this was coming? Maybe we should keep you subscribed to the relevant sub-tasks so you can see this kind of thing coming?

I also didn't know it was coming (except when I happened to ask about it minutes before the deployment), so Joe and myself also didn't have much of an opportunity to review whether the default thresholds made sense for this model and how we might want to tweak them. The main use case for tweaking these settings is unusually weak or strong models, and frwiki's model is fairly weak. For this reason it would also have been helpful for us to have been notified about the upcoming deployment.

I'll let @Trizek-WMF fully answer the question about how to best notify, but at a minimum you should tag User-notice for things that ... users will notice :) . This tag feeds into the weekly Tech News updates.

Ping @jmatazzoni. Should we expect ORES' basic functionality to still work without enabling the new filters?

The preferences are set up to give users the ability to use basic ORES functions without opting in to the beta—and to continue using most of them after opting in, if they choose. But since there were no pre-existing French ORES users, no one will be opted in to those preferences by default. I'd expect people interested in ORES to want to try the beta, but I suppose it's useful as well to publicize the other new options the French will have.

@Trizek-WMF, fair point. We'd made announcements via our own channels, but I can see why post on frwiki ahead of time would have been better. What would have been a better way for you to know that this was coming? Maybe we should keep you subscribed to the relevant sub-tasks so you can see this kind of thing coming?

Yes, absolutely.

Like the TCG says, "Have a clearly communicated release plan" would help a lot. It can be done very simply: just update tasks before a release, ping volunteers who required the ORES service and telle them when you are going to do the change and what would be the impact.

If you cc me, I can help you follow up with communities.

I also didn't know it was coming (except when I happened to ask about it minutes before the deployment), so Joe and myself also didn't have much of an opportunity to review whether the default thresholds made sense for this model and how we might want to tweak them. The main use case for tweaking these settings is unusually weak or strong models, and frwiki's model is fairly weak. For this reason it would also have been helpful for us to have been notified about the upcoming deployment.

Differences in models are an example of a change that can annoy communities. :)
I haven't sent a message to the fr.wp community yet, because I don't know what to announce concerning the models.

I'll let @Trizek-WMF fully answer the question about how to best notify, but at a minimum you should tag User-notice for things that ... users will notice :) . This tag feeds into the weekly Tech News updates.

User-notice is for changes that will impact all or almost all communities. User-notice-collaboration is more appropriate fr communication, because this change is related to a Collaboration team product (but released once a month). So a message sent in advance to the concerned community is the best way to achieve this.

Halfak closed this task as Resolved.Jul 12 2017, 10:49 PM