Proofreads tools do not load reliably with extended toolbar
Closed, ResolvedPublic

Description

While opening multiple (eg. 20-30) pages in Page namespace in separate tabs in Firefox the proofread tools are often (70-80%) absent from toolbar. Reloading the page does not fix the problem.

Everything works fine with the old toolbar.
Proofread tools are critical for Wikisource project.

I noticed also, that the new toolbar make FF 30-40% higher memory consuming. Unsure if it does matter.

Ankry created this task.Jun 7 2017, 4:36 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 7 2017, 4:36 PM
matmarex claimed this task.Jun 7 2017, 5:06 PM

I've tried this a few times in Chrome and Firefox, and it occasionally breaks in both of them – but in Chrome it's 90% working, 10% broken, while in Firefox it's the opposite. It's not specific to MonoBook, I see the same on Vector.

For reference, here's a screenshot of the page (https://pl.wikisource.org/w/index.php?title=Strona:Wac%C5%82aw_Sieroszewski-Na_kresach_las%C3%B3w.djvu/48&action=edit&redlink=1) when the proofread tools fail to load:

And a screenshot when the proofread tools load:

Change 357655 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/ProofreadPage@master] ext.proofreadpage.page.edit: Really wait for WikiEditor to load before adding proofread tools

https://gerrit.wikimedia.org/r/357655

Change 357655 merged by jenkins-bot:
[mediawiki/extensions/ProofreadPage@master] ext.proofreadpage.page.edit: Really wait for WikiEditor to load before adding proofread tools

https://gerrit.wikimedia.org/r/357655

Jdforrester-WMF closed this task as Resolved.Jun 8 2017, 3:48 PM