Update Ace Editor library to a more recent version
Closed, ResolvedPublic

Description

The ace editor library hasn't been updated for more than a year. Many important changes were made.

For example, currently CodeEditor conflicts with Chinese input method. This has been resolved in the upstream.

See also the request on the talk page :https://www.mediawiki.org/wiki/Topic:Tat8gxmbmjtpn5dl

Reasno created this task.Jun 12 2017, 3:02 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 12 2017, 3:02 PM
Aklapper renamed this task from Update Ace Editor to Update Ace Editor library to a more recent version.Jun 12 2017, 3:52 PM
TheDJ moved this task from Backlog to Up next on the CodeEditor board.Aug 6 2017, 2:12 PM
Paladox added a subscriber: Paladox.Aug 6 2017, 2:22 PM

Change 304044 had a related patch set uploaded (by TheDJ; owner: Paladox):
[mediawiki/extensions/CodeEditor@master] Update ace to 06.08.2017

https://gerrit.wikimedia.org/r/304044

Jdforrester-WMF closed this task as Resolved.Aug 9 2017, 3:51 PM
Jdforrester-WMF assigned this task to Paladox.

Change 304044 merged by jenkins-bot:
[mediawiki/extensions/CodeEditor@master] Update ace to 06.08.2017

https://gerrit.wikimedia.org/r/304044