Edit summary length counter and popup disagree
Closed, ResolvedPublic1 Story Points

Description

According to the little number I have 43 characters left, according to the popup I already have 12 too many:

Add mention of interwiki search so that users find out about it from the help link, after [[mailarchive:discovery/2017-June/001539.html|[discovery] Search update: sister project snippets are now in production!]].

Nemo_bis created this task.Jun 18 2017, 9:37 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 18 2017, 9:37 AM

I can reproduce in Firefox (though there instead of a popup I just get a red border; and - even worse - I can't submit the form).
The input has maxlength="200" set (for non-JS-clients). This limit should be removed (or increased to 255) by jquery.byteLimit.js, but apparently something is broken in the OOUI design. Probably T168042: Infusing EditPage's OOUIs widget resets the accesskey in tooltips (conflict with jquery.accessKeyLabel) is related, note that the tooltip has no prefix for the accesskey as described there, and probably the same code that reset the title attribute also reset the maxlength.

Probably caused by 5e4b02c or one of it follow-ups. $( '#wpSummary' ).byteLimit( 255 ); happens before infusing there, so is likely to be (partially) overridden by the infusion, causing the original limit to come into effect again.

matmarex triaged this task as Normal priority.Jun 19 2017, 7:42 PM
matmarex claimed this task.

Change 359980 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/core@master] mw.action.edit: Fix byte limit for the edit summary field

https://gerrit.wikimedia.org/r/359980

Change 359980 merged by jenkins-bot:
[mediawiki/core@master] mw.action.edit: Fix byte limit for the edit summary field

https://gerrit.wikimedia.org/r/359980

Jdforrester-WMF closed this task as Resolved.Jun 20 2017, 3:02 PM
Jdforrester-WMF edited projects, added Editing-team; removed Patch-For-Review.
Jdforrester-WMF set the point value for this task to 1.

Aha, had noticed this yesterday, thanks for the fix!