Page MenuHomePhabricator

<title> is still "Editing ..." after page is published
Closed, ResolvedPublic1 Story Points

Description

After editing and publishing (saving) a page the title field and tab header in Firefox still says Redigera (Edit), even though I'm not editing the page.

Running Ubuntu 16.04 LTS and Firefox 53.0.2 (64-bitars)

Details

Related Gerrit Patches:

Event Timeline

matmarex added a subscriber: matmarex.

I'm assuming this was with the visual editor (or the new wikitext editor), correct?

Restricted Application added a project: VisualEditor. · View Herald TranscriptJun 19 2017, 6:11 PM

I'm assuming this was with the visual editor (or the new wikitext editor), correct?

Yes, it was with the new Wikitext editor.

Deskana triaged this task as Low priority.Jun 20 2017, 10:42 AM
Deskana moved this task from To Triage to TR1: Releases on the VisualEditor board.
matmarex renamed this task from Firefox title field and tab header still says Redigera (Edit) after page is published. to Firefox title field and tab header still says "Editing" after page is published.Jun 26 2017, 5:28 PM
Esanders renamed this task from Firefox title field and tab header still says "Editing" after page is published to <title> is still "Editing ..." after page is published.Jun 30 2017, 5:05 PM
Esanders added a subscriber: Esanders.

This only happens when you load the page via action=edit

Change 362443 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/extensions/VisualEditor@master] Regenrate title in all non-view page scenarios

https://gerrit.wikimedia.org/r/362443

Change 362443 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] DesktopArticleTarget: Regenerate title in all non-view page scenarios

https://gerrit.wikimedia.org/r/362443

Deskana closed this task as Resolved.Jul 3 2017, 5:53 PM
Deskana claimed this task.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptJul 3 2017, 5:53 PM
Deskana reassigned this task from Deskana to Esanders.Jul 3 2017, 5:55 PM
Deskana set the point value for this task to 1.
Deskana added a subscriber: Deskana.

I fought against the same issue a couple of years ago.

For some browsers the <title> element might get new content.

However, some do not expect changing titles. There it became necessary to remove the <title> entirely from DOM and insert a new one, which I do always after that experience and it worked properly.

From the JS perspective the new text was stored and could be retrieved again, but it was not the same as displayed in the system which kept the old one.

I don’t know how that is implemented right now.

The tab title displaying editing occurs when you first open VE and then switch to source mode make make changes the publish those changes, to its as if the first action of changing the title to editing via VE hasnt been closed down when the switch takes place, I using chrome Version 66.0.3359.181 (Official Build) (64-bit) in windows 10

Gnangarra reopened this task as Open.Jun 14 2018, 7:38 AM

Reopen this as the issue is occurring,

@Gnangarra Thanks for the report. I'll split it to a separate task rather than reopen this one, if you don't mind. It seems to be a separate issue.