Page MenuHomePhabricator

Previews of citations generated by templates in subpages give incorrect internal redlinks
Closed, ResolvedPublic1 Story Points

Description

E.g. https://en.wikipedia.org/wiki/User:Quiddity_(WMF)/sandbox?oldid=788890181&veaction=edit
Shows


(redlinks in Firefox, bluelinks in Chrome, but both point to the same non-existent page)

Event Timeline

Quiddity created this task.Jul 4 2017, 8:03 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 4 2017, 8:03 PM
Quiddity updated the task description. (Show Details)Jul 4 2017, 8:04 PM
matmarex claimed this task.Jul 7 2017, 1:56 PM
Deskana triaged this task as Normal priority.Jul 14 2017, 9:58 AM
Deskana moved this task from To Triage to TR1: Releases on the VisualEditor board.
matmarex updated the task description. (Show Details)Sep 6 2017, 12:47 PM
matmarex renamed this task from Citation previews in subpages give incorrect internal redlinks to Previews of citations generated by templates in subpages give incorrect internal redlinks.Sep 6 2017, 12:57 PM

The root cause is T175157: Copy-paste of template-generated link from a subpage in VE gives the wrong href, because apparently these previews use the same rendering mode as rendering for clipboard (for copy-paste). I think that's wrong, but changing it causes more issues. I'm adding a note about this in https://gerrit.wikimedia.org/r/376262.

Change 376507 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/VisualEditor@master] Do not "resolve attributes" in toDomElements() overrides

https://gerrit.wikimedia.org/r/376507

Change 376507 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Do not "resolve attributes" in toDomElements() overrides

https://gerrit.wikimedia.org/r/376507

@Deskana This should also be resolved with the fix for T175157.

Deskana closed this task as Resolved.Sep 20 2017, 11:08 AM
Deskana set the point value for this task to 1.

@Deskana This should also be resolved with the fix for T175157.

Excellent! Thanks. :-)

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptSep 20 2017, 11:08 AM