Page MenuHomePhabricator

Please turn on mapframe for Czech Wikipedia
Closed, ResolvedPublic

Description

Please turn on mapframe for cswiki, consensus at CS:Wikipedie:Pod_lípou_(technika)#Mapframe_pro_českou_Wikipedii.

As per similar request here: T161032: Please turn on mapframe for Swedish Wikipedia

Details

Related Gerrit Patches:
operations/mediawiki-config : masterEnable mapframe for cswiki

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 25 2017, 1:57 PM
Urbanecm claimed this task.Jul 25 2017, 2:35 PM
Urbanecm triaged this task as Medium priority.
Restricted Application added a project: User-Urbanecm. · View Herald TranscriptJul 25 2017, 2:35 PM
debt added a subscriber: debt.Jul 25 2017, 2:52 PM

Can the description be updated? The phab task mentioned in the description doesn't correlate to this request:

As per similar request here: https://phabricator.wikimedia.org/T16103

Thanks for noticing. Updated :-)

matej_suchanek added a subscriber: matej_suchanek.
debt added a subscriber: CKoerner_WMF.

Thanks for the update to the ticket description, @Vojtech.dostal :)

Please see the conversation here about deploying mapframe to your wiki.

Thanks @debt for the link. It would be indeed cool if we could deploy it on our own. Maybe @matej_suchanek or @Urbanecm could help? :-)

debt awarded a token.Jul 25 2017, 5:31 PM

@debt Do you think I can process this request by changing the site config? Or should I get approval from somebody? Or something else?

JAnD added a subscriber: JAnD.Jul 26 2017, 9:41 AM

@JGirault any thought on this task?

debt added a comment.Jul 26 2017, 2:06 PM

@Urbanecm: in theory, this request can be (somewhat easily) fulfilled by editing a configuration file for mapframe sites and deploying it into production. The ability to do that requires admin rights to edit the file and the ability to do production releases during normal SWAT windows.

The issue that we have is that we, the Maps team, do not have the engineering resources to support any requests for feature updates or any bugs that aren't critical, as I noted in my comment earlier.

We are having an internal conversation on the feasibility of updating the mapframe site configuration file—as a one-off request—for your wiki and for the 3 other site requests that we've received. We still will not be able to support any feature requests or minor bug fixes related to the map service, but if we decide to undertake this one-off request, it would allow further usage of the maps service on 4 Wikipedias that currently only have access to the maplink functionality.

I know how can be this request processed - I process similar requests on regular basis. So just to be sure I understand you correctly. The problem is that you can't maintain the extension?

Gehel added a subscriber: Gehel.Jul 27 2017, 10:25 AM

@Urbanecm We do not expect any particular technical issues with enabling mapframe to more small wikis (large wikis like enwiki might be an issue in term of load).

The maps-team is very short on engineering resources at the moment. So the risk is that additional use cases will be discovered by new communities and that we won't have the resources to implement those new use cases. We have enough resources to maintain the extension in its current state and to fix any current feature that is obviously broken, but not to evolve it. As long as this restriction is understood, we have no objection to enabling mapframe further. We just want to manage the expectation...

Ok, thank you for your final explanation.

Change 368167 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[operations/mediawiki-config@master] Enable mapframe for cswiki

https://gerrit.wikimedia.org/r/368167

Going to process then.

Urbanecm moved this task from Backlog to To deploy on the User-Urbanecm board.Jul 27 2017, 12:34 PM
debt moved this task from Backlog to Needs review on the Maps-Sprint board.Jul 27 2017, 12:41 PM

Change 368167 merged by jenkins-bot:
[operations/mediawiki-config@master] Enable mapframe for cswiki

https://gerrit.wikimedia.org/r/368167

Mentioned in SAL (#wikimedia-operations) [2017-07-27T13:08:05Z] <hashar@tin> Synchronized wmf-config/InitialiseSettings.php: Enable mapframe for cswiki - T171588 (duration: 00m 47s)

Urbanecm closed this task as Resolved.Jul 27 2017, 1:15 PM

Activated.

debt moved this task from Needs review to Done on the Maps-Sprint board.Jul 27 2017, 1:47 PM