Page MenuHomePhabricator

Applying pending changes protection and extended confirmed users in idwiki
Open, LowPublic

Description

There is a consensus there to change the FlaggedRevs system to Pending changes and extended confirmed users like en.wiki. I hope the user with editor rights will be changed to reviewer rights like en.wiki.

https://id.wikipedia.org/wiki/Wikipedia:Permohonan_pendapat/Penerapan_perubahan_tertunda_dan_pengguna_terkonfirmasi_lanjutan

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 8 2017, 11:02 PM
Arifin.wijaya triaged this task as High priority.Aug 8 2017, 11:15 PM
Kenrick95 added a subscriber: Kenrick95.
Restricted Application added a subscriber: Dereckson. · View Herald TranscriptAug 11 2017, 1:08 PM
MarcoAurelio lowered the priority of this task from High to Low.Aug 13 2017, 7:06 PM
MarcoAurelio added a subscriber: MarcoAurelio.

Are you sure? Enwiki is fairly big and really needs such thing. I do oppose doing the deploy for your wiki.

Arifin.wijaya added a comment.EditedAug 14 2017, 12:54 AM

User in id.wiki support to change the FlaggedRevs system to pending changes system because of massive vandalism and many biography and television article in id.wiki is in vandalism. So I hope to change that system to the pending changes system because vandalism is happened to id.wiki. Many users in id.wiki support to change that system so there are consensus in id.wiki. You can see in that proposal. Ratio total admin and total article in id.wiki are small: 35:407.813. There are the consensus in that proposal.

Vandalism is increasingly rampant in the id.wiki (especially articles related to football, television, soap operas, and railways), lack of user with editor rights are active in handling vandalism, because some users who volunteered as editors simply because they want to carry that status only, also the traffic on id.wiki is quite high as in other large Wikipedia. So I hope to change the FlaggedRevs system into pending changes system. I think the FlaggedRevs system is more suitable to be applied on a small wiki like jv.wiki, id.wiktionary, ms.wiki, etc.

Urbanecm closed this task as Declined.Aug 14 2017, 1:14 AM

No, this thing is getting to far imho. See discussion at Z398 too.

Well, I reopen the proposal in id.wiki to see what wrong to that proposal because I think this thing is related to the topic.

Akmaie_Ajam reopened this task as Open.Fri, Oct 9, 10:16 AM
Akmaie_Ajam added a subscriber: Akmaie_Ajam.

Hello, I'm Akmaie Ajam. I'm reopening this because:

  1. Pages with FlaggedRevs often didn't have any vandalism in the page history. Proof: https://id.wikipedia.org/w/index.php?title=Sara_Fajira&action=history and https://id.wikipedia.org/w/index.php?title=Scuba&action=history
  2. Even with vandalism in the page history, most of them were old and not ongoing (a month or more). Proof: https://id.wikipedia.org/w/index.php?title=Selam_skuba&action=history
  3. I often translate and fix mistakes, which are common in the Indonesian Wikipedia, and this delays delivery of my edits to the general readers, because edits made by autoconfirmed users do not bypass the FlaggedRevs system.
  4. There are edits that have been delayed for over 4 years. Proof: https://id.wikipedia.org/w/index.php?title=Istimewa:Halaman_tertinjau_usang&limit=100
  5. As Arifin.wijaya said, there is consensus to replace FlaggedRevs.
  6. With over 500.000 articles, the Indonesian Wikipedia is just too large to apply pending changes protection to almost all articles. I think FlaggedRevs is better for wikis with under 10.000 articles.
  7. Lack of active editors to review revisions.
  8. For articles with occasional vandalism attacks from IP addresses and non-autoconfirmed users, I think it's better to just apply protection when it's ongoing rather than forever and delaying good user's edits.

Thank you for reading.

Akmaie_Ajam raised the priority of this task from Low to Medium.Fri, Oct 9, 1:27 PM

I think the proposal is helpful long-term to implement. It makes edits go live faster (way faster), including helpful ones (like adding information or fixing typos), and the backlog of unreviewed articles would go down, decreasing the load for editors. I fix mistakes and cleanup articles, and, more often than not, my edit is delayed because of FlaggedRevs, so I think this deserves a priority increase. Thank you for reading.

Aklapper lowered the priority of this task from Medium to Low.Fri, Oct 9, 1:38 PM

Hmm, do you plan to work on fixing this task, as you increased the priority of this task? You are welcome to increase priority and set yourself as task assignee if you plan to work on fixing this, as the Priority field summarizes and reflects reality and does not cause it. Thanks.

Well, sorry, I do not know how to fix it. However, I think it is important to remove FlaggedRevs, because it delays helpful edits.

I want to quote @Aklapper because I want to work with you (Aklapper) and fix this. I forgot (haven't known about quoting until I read https://www.mediawiki.org/wiki/Phabricator/Project_management#Setting_task_priorities) to do this earlier.

Veracious added a subscriber: Veracious.

I want the Indonesian Wikipedia bureaucrats and administrators to know this so we can replace FlaggedRevs sooner.
(Saya ingin birokrat dan pengurus Wikipedia Indonesia untuk mengetahui ini agar kita bisa lebih cepat mengganti FlaggedRevs.)