Page MenuHomePhabricator

The names of new Saved Filters don't appear as expected in the Active Filter area
Closed, ResolvedPublic

Description

  • On Recent Changes, delete all filters with Trashcan then make some new selections.
  • Click bookmark and give the setting a name.
  • (The name will not appear immediately in the Active area, which is OK, since we just saved it.)
  • Now use Saved filters menu and select a different Saved Filter.
    • OR click trashcan to delete all filters.
  • Then select the new filter we just saved.

Expected result: the filter loads and its name shows up in the Active Filers area.
Actual result: Whether you select a different filter then come back, or use Trashcan to delete all filters, the new saved filter loads but its name does not appear. You have to click in the address bar and reload the page to make the new name start appearing.

Details

Related Gerrit Patches:

Event Timeline

(The name will not appear immediately in the Active area, which is OK, since we just saved it.)

The name should appear immediately. That would help confirming that the filter was saved.

There is also a related issue: deleting a saved filter while it is being the active one keeps the name next to the active filters label and the bookmark action hidden. The expected behaviour would be to for the label to disappear when the filter is deleted and the bookmark action to appear.

We can include these as part of the current ticket or create separate ones depending on how much related the issues actually are.

Change 374402 had a related patch set uploaded (by Mooeypoo; owner: Mooeypoo):
[mediawiki/core@master] RCFilters: Minimize saved query before comparison

https://gerrit.wikimedia.org/r/374402

Change 374402 merged by jenkins-bot:
[mediawiki/core@master] RCFilters: Minimize saved query before comparison

https://gerrit.wikimedia.org/r/374402

Checked the fix in betalabs.

Etonkovidova closed this task as Resolved.Aug 29 2017, 5:01 PM