Page MenuHomePhabricator

[epic] Upgrade to elastic 5.5.x
Closed, ResolvedPublic

Description

In order to upgrade to the latest Kibana release (it fixes a cross-site-scripting issue as noted in T173685), we'll need to upgrade various parts of the search stack to es 5.5.x::

*and probably more as es 5.5 is likely to be much more strict

Event Timeline

dcausse created this task.Aug 31 2017, 9:48 AM
Restricted Application added a project: Discovery. · View Herald TranscriptAug 31 2017, 9:48 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
debt renamed this task from Upgrade to elastic 5.5.x to [epic] Upgrade to elastic 5.5.x.Aug 31 2017, 12:46 PM
debt triaged this task as High priority.
debt edited projects, added Discovery-Search (Current work); removed Discovery-Search.
debt updated the task description. (Show Details)
debt added subscribers: Gehel, EBernhardson, Smalyshev, TJones.
debt assigned this task to dcausse.Aug 31 2017, 5:11 PM
debt added a subscriber: debt.

Assigning to David as he's our expert in this type of work, but others on the team will be helping.

Gehel added a comment.Sep 5 2017, 5:02 PM

Side note, since we stopped to deploy our plugins to the logstash cluster (T174933), we have one less constraint to upgrade it. So we could start on the logstash cluster already now...

We'll finish this after the rolling restart of servers happen...a few things yet to be done (security patch, etc).

debt added a subtask: Restricted Task.Oct 17 2017, 5:35 PM
debt closed subtask Restricted Task as Resolved.Dec 8 2017, 8:43 PM
debt closed this task as Resolved.Dec 8 2017, 8:46 PM

Great job, everyone — woohoo! :)