Page MenuHomePhabricator

CAPTCHA ineffective, consider using reCAPTCHA
Closed, DeclinedPublic

Description

CAPTCHA is ineffective in keeping spambots out. Replace CAPTCHA with reCAPTCHA. It is more accessible and better at keeping bots out than ordinary CAPTCHAs.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 2 2017, 6:14 PM

See https://en.wikipedia.org/wiki/Wikipedia:Perennial_proposals#Use_reCAPTCHA and T34695: Implement, Review and Deploy Wikicaptcha

I instead think that WMF should develop a better (preferred standalone) CAPTCHA service which can be used by Wikimedia sites, external MediaWiki sites and tools hosted in Cloud VPS and Toolforge (currently some tools uses reCAPTCHA which is not consistent with T133919).

Florian added a subscriber: Florian.

I assume, that you ask, that Wikimedia wikis should use reCaptcha, right? I remove the ConfirmEdit tag, as ConfirmEdit already supports the reCaptcha service, and it just has to be included in the configuration (instead of using another CAPTCHA module), so there's nothing to do in the ConfirmEdit extension :)

Krenair added a subscriber: Krenair.EditedSep 2 2017, 7:19 PM

My understanding is that it was considered not an option in 2008 for reasons that AFAIK have not changed, so this is probably a duplicate of a wontfix.

As someone who has locked thousands of spambots, and continue to do so, any help in stopping the registration of that crap would certainly help. I can understand however the privacy concerns on using an external service like Google reCaptcha.

1- That captcha is not accessible, is annoying (all captchas are to some point, though), slow to solve, sometimes ambiguous, and generally a pain to pass (even in the best case).

2- It would be a gross violation of WMF current Privacy Policy.

Legoktm closed this task as Declined.Sep 3 2017, 4:25 AM