Page MenuHomePhabricator

NavPopups conflicts with Page previews on Italian Wikipedia
Closed, ResolvedPublic1 Estimated Story Points

Description

Steps to reproduce:

  1. Visit it.wikipedia.org
  2. Log in
  3. Enable Popup di navigazione (NavPopups) in user preferences
    1. https://it.wikipedia.org/wiki/Speciale:Preferenze#mw-prefsection-gadgets
  4. Visit an article and hover over a link.

Both features appear, sometimes overlapping.

Expected behavior: After enabling NavPopups gadget, Page Previews should be suppressed.

Acceptance criteria

'itwiki' => 'Popup'

Event Timeline

Restricted Application added a subscriber: Aklapper. ยท View Herald TranscriptOct 17 2017, 9:11 PM
Restricted Application added a subscriber: TerraCodes. ยท View Herald TranscriptOct 17 2017, 9:15 PM
ovasileva triaged this task as Medium priority.Oct 18 2017, 9:17 AM
phuedx updated the task description. (Show Details)Oct 18 2017, 10:28 AM
phuedx set the point value for this task to 1.
phuedx added a subscriber: phuedx.

As this is a config change.

phuedx updated the task description. (Show Details)Oct 18 2017, 10:32 AM
Elitre added a subscriber: Elitre.Oct 18 2017, 11:45 AM

Change 385007 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[operations/mediawiki-config@master] Use correct name for gadgets popup on itwiki

https://gerrit.wikimedia.org/r/385007

Change 385007 merged by jenkins-bot:
[operations/mediawiki-config@master] Use correct name for gadgets popup on itwiki

https://gerrit.wikimedia.org/r/385007

phuedx claimed this task.Oct 19 2017, 8:55 AM

Stand back! I'm going to try science!

phuedx closed this task as Resolved.Oct 19 2017, 9:01 AM

๐ŸŽ‰๐ŸŽ‰๐ŸŽ‰

I tested the following scenarios on itwiki:

  1. Enable Page Previews
    1. Navigate to Special:Preferences
    2. Enable Page Previews
    3. Dwell on a link
    4. Observe that a preview appears ๐Ÿ‘
  2. Enable Page Previews and the NavPopups gadget
    1. Navigate to Speciale:Preferences#mw-prefsection-gadgets
    2. Enable the gadget
    3. Observe that Page Previews can't be enabled or disabled as it's overridden by the gadget ๐Ÿ‘
    4. Dwell on a link
    5. Observe that a navigation popup (a NavPopup?) appears ๐Ÿ‘
phuedx reopened this task as Open.Oct 19 2017, 10:38 AM

I may have spoken to soon. @Elitre reports that they are still seeing Page Previews and NavPopups at the same time.

Elitre closed this task as Resolved.Oct 19 2017, 11:21 AM

We determined this was actually due to me invoking NavPopups from my global.js at Meta.

I've captured updating the generic message that we display to users about possible conflicts with gadgets in T178566: Mention global JS in NavPopups conflict message.