Page MenuHomePhabricator

[wmf.7] "Excluded" label is displayed with filter selection
Closed, ResolvedPublic

Description

The issue is present in wmf.7, wmf.8, and betalabs.

  1. On the RC page with the New filters, select some filters and select Namespace filters. Exclude that Namespace filter.
  2. The label "Excluded" will be displayed for the excluded Namespace(s) (correct). Also it will be displayed for the selected filter in the Filter drop-down menu.

3.Remove the excluded Namespace filter - the selected filters still display 'Excluded' label.
Btw, the result set won't be affected, i.e. the results fetched by the selected filter won't be excluded.

Reloading the page won't help - "Excluded" will be added to any subsequent filter selection.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 18 2017, 12:40 AM

Change 392179 had a related patch set uploaded (by Mooeypoo; owner: Mooeypoo):
[mediawiki/core@master] RCFilters: Only apply excluded label to namespace items

https://gerrit.wikimedia.org/r/392179

This was a mishap due to the fix for T177009: Only add highlight/toggle states conditionally to the saved queries

Fixed in the above commit.

Change 392179 merged by jenkins-bot:
[mediawiki/core@master] RCFilters: Only apply excluded label to namespace items

https://gerrit.wikimedia.org/r/392179

Change 392465 had a related patch set uploaded (by Catrope; owner: Mooeypoo):
[mediawiki/core@wmf/1.31.0-wmf.8] RCFilters: Only apply excluded label to namespace items

https://gerrit.wikimedia.org/r/392465

Change 392465 merged by jenkins-bot:
[mediawiki/core@wmf/1.31.0-wmf.8] RCFilters: Only apply excluded label to namespace items

https://gerrit.wikimedia.org/r/392465

Mentioned in SAL (#wikimedia-operations) [2017-11-20T20:07:14Z] <ladsgroup@tin> Synchronized php-1.31.0-wmf.8/resources/src/mediawiki.rcfilters/ui/mw.rcfilters.ui.ItemMenuOptionWidget.js: RCFilters: Only apply excluded label to namespace items (T180863) (duration: 00m 49s)

Change 392477 had a related patch set uploaded (by Mooeypoo; owner: Mooeypoo):
[mediawiki/core@master] RCFilters: Followup I08db859c571: Fix typo in "namespaces"

https://gerrit.wikimedia.org/r/392477

Change 392479 had a related patch set uploaded (by Catrope; owner: Mooeypoo):
[mediawiki/core@wmf/1.31.0-wmf.8] RCFilters: Followup I08db859c571: Fix typo in "namespaces"

https://gerrit.wikimedia.org/r/392479

Change 392477 merged by jenkins-bot:
[mediawiki/core@master] RCFilters: Followup I08db859c571: Fix typo in "namespaces"

https://gerrit.wikimedia.org/r/392477

Checked in enwiki (wmf.8) - the issue is fixed.

Etonkovidova closed this task as Resolved.Nov 20 2017, 11:09 PM

Change 392479 merged by jenkins-bot:
[mediawiki/core@wmf/1.31.0-wmf.8] RCFilters: Followup I08db859c571: Fix typo in "namespaces"

https://gerrit.wikimedia.org/r/392479

Mentioned in SAL (#wikimedia-operations) [2017-11-21T00:19:31Z] <catrope@tin> Synchronized php-1.31.0-wmf.8/resources/src/mediawiki.rcfilters/ui/mw.rcfilters.ui.ItemMenuOptionWidget.js: T180863 (duration: 00m 49s)