Page MenuHomePhabricator

When campaigns have only 1 kind of license, trying to upload images to Commons fails at "Release Rights" step: clicking "Next" button does nothing
Closed, ResolvedPublic

Description

A report has been made about this on Facebook in relation to the Wiki Loves Africa contest. Here is the link: https://www.facebook.com/groups/1948226822099948/permalink/2011289432460353/.

Content of the above link;

URGENT: Hello Everyone! We are aware there is a problem with uploading to Commons. We have told the facebook page that we will accept entries for another 24 hours. .. but we have connectivity issues ourselves and would be grateful if someone could figure out what is wrong on Commons and ask to get it fixed!! And please can someone put a notice on the upload page on Commons (on each of the language versions) to notify uploaders that we are aware of the problem and they have an additional 24 hours to upload their images.

Can this be looked at? Thanks

Event Timeline

D3r1ck01 created this task.Nov 30 2017, 5:28 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 30 2017, 5:28 PM
Restricted Application added a project: TCB-Team. · View Herald TranscriptNov 30 2017, 5:32 PM
D3r1ck01 triaged this task as High priority.Nov 30 2017, 5:38 PM
D3r1ck01 updated the task description. (Show Details)

Here is the link: https://www.facebook.com/groups/1948226822099948/permalink/2011289432460353/.

And what's the content? For me it says 'You must log in to continue.'

D3r1ck01 updated the task description. (Show Details)Nov 30 2017, 6:30 PM

Okay @zhuyifei1999, I have edited task description and added link content.

D3r1ck01 updated the task description. (Show Details)Nov 30 2017, 6:32 PM

We are aware there is a problem with uploading to Commons.

What exactly is the problem? There are still people uploading AFAICT. Any steps to reproduce the problem?

Aklapper changed the task status from Open to Stalled.Nov 30 2017, 9:11 PM

Hi @D3r1ck01, thanks for taking the time to report this!
Unfortunately this task needs way more information... Currently we only know that someone somewhere has some problem so nobody can investigate.

If you have time and can still reproduce the problem: Please add a more complete description to this report (a list of steps to reproduce which leave no room for interpretation what to do, describing actual results and expected results after performing the steps to reproduce. You can edit the task description by clicking Edit Task.
Ideally, exact and clear steps to reproduce should allow any other person to follow these steps (without having to interpret those steps) and see the same results. Problems that others can reliably reproduce can get fixed faster. Thanks!

Anthere added a subscriber: Anthere.Dec 1 2017, 8:10 AM

Problem was reported by MANY people across Africa so it is unlikely to be a connectivity issue.
I am in South Africa myself at the moment; I face the problem myself. I can not upload images using the WLA wizard whilst I can perfectly upload images using the generic upload system on Commons.

The WLA wizard is here : https://commons.wikimedia.org/w/index.php?title=Special:UploadWizard&campaign=wlafrica&description=&descriptionlang=en

I select the image. I click on continue. It leads me to the next step which is the "Release Rights".

The upload system gets stuck at the Release Rights step. Clicking on the "Next" button does not make any difference.

The expected results is that clicking on the "next" button would lead us to the next screen/step of the process which is "description".

This completely reproducible (meaning... it never works. It is not a random issue happening or not happening. It just does NOT happen). I can only check it from South Africa though.

I changed the preferences languages (I tested French and English) and it makes no difference.

The contest in itself is now closed.
But some UserGroups could not upload the images they collected as part of the contest. Means hundreds of images. They can upload using the regular upload system (which I recommended they do), but there is a high risk related to wrong tagging (which would mean hours of volunteer work fixing tagging afterwards). So yeah... if it can be fixed :----> better

Lea_WMDE added a subscriber: Lea_WMDE.

Removing "Move Files to Commons" tag since this is (maybe not the best label) for a new extension that is not yet on production.

Aklapper edited projects, added UploadWizard; removed TCB-Team.Dec 1 2017, 1:09 PM

I thought I've seen this reported before but could only find old T95599: When using UploadWizard, clicking the "Next" button on the "Describe" page has no effect.

@Anthere, @D3r1ck01: If you can still reproduce this problem:

When this happens, does anything appear in your browser's JavaScript console when loading the page? Sometimes JavaScript errors are a reason for problems. For more information please see:

Could you try to run the upload wizard with the debug option enabled? Just add debug=true as a URL parameter, like going to https://commons.wikimedia.org/w/index.php?title=Special:UploadWizard&campaign=wlafrica&description=&descriptionlang=en&debug=true

As this has happened to several people, any patterns about the web browsers being used by the affected people?

Restricted Application added a project: Multimedia. · View Herald TranscriptDec 1 2017, 1:09 PM
Aklapper renamed this task from Issues uploading pictures on Wikimedia Commons to Trying to upload images to Wikimedia Commons: At "Release Rights" step, clicking "Next" button does nothing.Dec 1 2017, 1:10 PM

Change 394593 had a related patch set uploaded (by Matthias Mullie; owner: Matthias Mullie):
[mediawiki/extensions/UploadWizard@master] Work around inconsistent $.when resolving

https://gerrit.wikimedia.org/r/394593

Patch is up.
It affects campaigns where only 1 kind of license (own work) can be selected (which is probably most/all of them).
Not sure how many of those are currently running; we may want to deploy this as soon as possible, rather than waiting for deployment train.

@matthiasmullie, thanks for working on this. Also @Aklapper, wasn't around for a while but I think @Anthere already gave some hints on how and where the problem occurs. Thanks to @matthiasmullie for acting this fast :).

Let's deploy as soon as we can. I'm okay with expediting through the regular process for this one, as long as code review is good.

Change 394593 merged by jenkins-bot:
[mediawiki/extensions/UploadWizard@master] Work around inconsistent $.when resolving

https://gerrit.wikimedia.org/r/394593

@Ramsey-WMF, you are up, could this be deployed so our WLA participants finish up with their uploads? @Anthere, do they still have some time or time is over?

We'll do our best to get it out as soon as possible.

Thank you very much @Ramsey-WMF. We'll be waiting.

Aklapper renamed this task from Trying to upload images to Wikimedia Commons: At "Release Rights" step, clicking "Next" button does nothing to When campaigns have only 1 kind of license, trying to upload images to Commons fails at "Release Rights" step: clicking "Next" button does nothing.Dec 1 2017, 4:58 PM
Aklapper changed the task status from Stalled to Open.

Change 394607 had a related patch set uploaded (by MarkTraceur; owner: Matthias Mullie):
[mediawiki/extensions/UploadWizard@wmf/1.31.0-wmf.10] Work around inconsistent $.when resolving

https://gerrit.wikimedia.org/r/394607

I have a backport patch being merged right now, going to deploy in the next 30 minutes.

Change 394607 merged by jenkins-bot:
[mediawiki/extensions/UploadWizard@wmf/1.31.0-wmf.10] Work around inconsistent $.when resolving

https://gerrit.wikimedia.org/r/394607

The fix is now deployed - can someone check that it's working now, please?

My preliminary test shows the Next button at the release rights step is working now. We could use more people testing it to make sure everything is okay.

Thanks @Ramsey-WMF and @MarkTraceur, let me update the participants on Facebook and let them test and give feedback. Thanks very much.

A few feedback from participants of the contest say it's working now. That all is well. Waiting for more feedback but I think all is well now. Thanks very much everyone :)

Awesome ! Thanks to all of you for your quick help ! Most appreciated !

Can we now mark this as resolved? Or is there anything else to be done?

matthiasmullie closed this task as Resolved.Dec 2 2017, 5:55 PM