Page MenuHomePhabricator

Watching changesets by new developers: [[mw:Gerrit/Reports/Open changesets by newbie owner]] or "C_Gerrit_Demo" on wikimedia.biterg.io
Closed, ResolvedPublic

Description

Looked at both Open changesets by newbie owner and Biterg's C_Gerrit_Demo, few noticings:

  • Last bot edit was made to the Open Changesets page on January 25th. I am not sure how the script works, but pulling some random names from the list and looking them up on Gerrit (https://gerrit.wikimedia.org/r/#/c/255083/) shows that the patch uploaded was from a newcomer quite a while ago, and same for other users. Also, the list contains usernames whose patches were taken care (merged) by other users quite a while ago. In short, we would need to optimize this script to meet our needs.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 7 2018, 4:22 PM
srishakatux triaged this task as Medium priority.EditedFeb 7 2018, 4:22 PM

@Aklapper So the question is: for watching changesets by new developers in Gerrit on a regular basis, would it make sense to rely on Biterg's C_Gerrit_Data?

@Aklapper So the question is: for watching changesets by new developers in Gerrit on a regular basis, would it make sense to rely on Biterg's C_Gerrit_Data?

@srishakatux: https://wikimedia.biterg.io/app/kibana#/dashboard/C_Gerrit_Demo provided by Bitergia (by the way; "Biterg" does not exist) does not offer changesets but only names and dates of people who/when they put their very first changeset into Gerrit, sorted by date of their first activity.
There is no direct link to see users' patches in Gerrit either. Note that the data is not automagically updated until T151161 is fixed, and I don't 100% trust the data until T185316 is fixed (though that is actually about a different table).

My understanding of https://www.mediawiki.org/wiki/Gerrit/Reports/Open_changesets_by_newbie_owner is that it provides names and direct links to Gerrit, but no dates and no date range options. It lists any people who ever put less than five patches into Gerrit, and that could have been five years ago (example: Yosnoop in that list), or I cannot even find their patch in Gerrit (example: Xavier Combelle in that list) for reasons I don't know.

So both places have advantages and disadvantages IMHO.

(Personally I don't think that "watch newcomers' patches" would be an actionable task yet for Q1/2018, given the technical constraints. In late 2016 I occassionally sent out requests for review to wikitech-l like this one but I had to stop that when we took down korma in Feb2017 due to changing platforms and related regressions, and now I'm waiting for T151161 to get fixed.)

On advantages and disadvantages of both, I wonder if that depends a lot on the process we end up designing/ developing for monitoring patches. I like the approach of utilizing an improved version of "Open changesets" stats that could be customized to show whatever we want to see in there.

Qgil assigned this task to Aklapper.Feb 27 2018, 12:42 PM
Qgil moved this task from Backlog to February on the Developer-Advocacy (Jan-Mar-2018) board.
Aklapper renamed this task from For watching changesets by new developers: Gerrit/Reports/Open changesets by newbie owner OR Biterg's C_Gerrit_Demo to Watching changesets by new developers: [[mw:Gerrit/Reports/Open changesets by newbie owner]] or "C_Gerrit_Demo" on wikimedia.biterg.io .Mar 1 2018, 4:46 PM

@srishakatux: Regarding Tech Community Metrics at https://wikimedia.biterg.io, could you check out / provide feedback on T187895#4014543 please?
(And of course at some point it would require fixing T151161, to always have fresh data.)

Meh. I was hoping this task is theoretically resolved by T187895#4014543 and practically only blocked on T151161, but I realize setting the time span to "last X days" of course does not also filter the gerrit_backlog_table widget to make it only display all and any patches authored by those users listed under 'new authors' (instead it of course shows patches by any authors within the given time span). Currently you either have filter by each author separately, or use all 'new author' names to construct a custom author_name:"Alice" OR author_name:"Bob" query.

I posted a longer related comment in T188244#4053930

Aklapper raised the priority of this task from Medium to High.Mar 19 2018, 12:28 PM
Aklapper closed this task as Resolved.Mar 27 2018, 3:32 PM

I favor using wikimedia.biterg.io as it's more powerful, hence closing this task.

Summarized in the parent task at T188244#4084927.