Page MenuHomePhabricator

[Regression wmf.21] Unable to upload images in the wikitext and visual editors
Closed, ResolvedPublic1 Story Points

Description

I'm unable to upload images in either Chrome (all extensions disabled) or Firefox (clean install) using the upload dialog in VE in both production and in Beta

I get "Something went wrong" error in both browsers but the errors seem different. From the console I get:

In Chrome Version 61.0.3163.100 (Official Build) (64-bit)

jQuery.Deferred exception: Cannot read property 'format' of undefined TypeError: Cannot read property 'format' of undefined
    at https://en.wikipedia.beta.wmflabs.org/w/load.php?debug=false&lang=en&modules=diffMatchPatch%2Coojs-ui%2Coojs-ui-core%2Coojs-ui-toolbars%2Coojs-ui-widgets%2Coojs-ui-windows%2Cpapaparse%2Crangefix%2Cspark-md5%2CtreeDiffer%2Cunicodejs%7Cext.CodeMirror.data%2Clib%2CvisualEditor%7Cext.CodeMirror.mode.mediawiki%7Cext.CodeMirror.visualEditor.init%7Cext.cite.style%2Cstyles%2CvisualEditor%7Cext.cite.visualEditor.core%2Cdata%7Cext.citoid.visualEditor%7Cext.citoid.visualEditor.data%7Cext.disambiguator.visualEditor%7Cext.geshi.visualEditor%7Cext.graph.data%2CvisualEditor%7Cext.kartographer%2CtemplateData%7Cext.kartographer.editing%2CvisualEditor%7Cext.math.styles%2CvisualEditor%7Cext.score.visualEditor%7Cext.templateData.images%7Cext.templateDataGenerator.data%2CeditPage%2Cui%7Cext.templateDataGenerator.ui.images%7Cext.visualEditor.articleTarget%2Cbase%2Ccore%2Cdata%2CdesktopArticleTarget%2CdesktopTarget%2Cdiffing%2Cicons%2Clanguage%2Cmediawiki%2CmoduleIcons%2Cmwalienextension%2Cmwcore%2Cmwdiffing%2Cmwextensionmessages%2Cmwextensions%2Cmwformatting%2Cmwgallery%2Cmwimage%2Cmwlanguage%2Cmwlink%2Cmwmeta%2Cmwsignature%2Cmwtransclusion%2Cswitching%2Cwelcome%7Cext.visualEditor.core.desktop%7Cext.visualEditor.mwextensions.desktop%7Cext.visualEditor.mwimage.core%7Cext.wikihiero.visualEditor%7Cmediawiki.ForeignStructuredUpload%2CForeignUpload%2CUpload%2Cwidgets%7Cmediawiki.ForeignStructuredUpload.BookletLayout%2Cconfig%7Cmediawiki.Upload.BookletLayout%7Cmediawiki.action.view.redirectPage%7Cmediawiki.api.edit%2Cmessages%2Cupload%7Cmediawiki.diff.styles%7Cmediawiki.language.names%7Cmediawiki.libs.jpegmeta%7Cmediawiki.page.gallery.styles%7Cmediawiki.skinning.content.parsoid%7Cmediawiki.widgets.CategoryMultiselectWidget%2CDateInputWidget%2CMediaSearch%2CStashedFileWidget%2CUserInputWidget%2Cstyles%7Cmediawiki.widgets.DateInputWidget.styles%7Coojs-ui.styles.icons-accessibility%2Cicons-editing-core%2Cicons-editing-list%2Cicons-editing-styling%2Cicons-layout%2Cicons-location%2Cicons-media%2Cicons-wikimedia&skin=vector&version=0ltfl92:2487:465

In Firefox ESR 45.9.0:

jQuery.Deferred exception: this.config is undefined ForeignStructuredUpload.prototype.getDescriptions/<@https://en.wikipedia.org/w/load.php?debug=false&lang=en&modules=diffMatchPatch%2Cmoment%2Coojs-ui%2Coojs-ui-core%2Coojs-ui-toolbars%2Coojs-ui-widgets%2Coojs-ui-windows%2Cpapaparse%2Crangefix%2Cspark-md5%2CtreeDiffer%2Cunicodejs%7Cext.CodeMirror.data%2Clib%2CvisualEditor%7Cext.CodeMirror.mode.mediawiki%7Cext.CodeMirror.visualEditor.init%7Cext.cite.style%2CvisualEditor%7Cext.cite.visualEditor.core%2Cdata%7Cext.citoid.visualEditor%7Cext.citoid.visualEditor.data%7Cext.disambiguator.visualEditor%7Cext.geshi.visualEditor%7Cext.graph.data%2CvisualEditor%7Cext.kartographer%2CtemplateData%7Cext.kartographer.editing%2CvisualEditor%7Cext.math.styles%2CvisualEditor%7Cext.score.visualEditor%7Cext.templateData.images%7Cext.templateDataGenerator.data%2CeditPage%2Cui%7Cext.templateDataGenerator.ui.images%7Cext.visualEditor.articleTarget%2Cbase%2Ccore%2Cdata%2CdesktopArticleTarget%2CdesktopTarget%2Cdiffing%2Cicons%2Clanguage%2Cmediawiki%2CmoduleIcons%[…] undefined

Event Timeline

Mvolz created this task.Feb 16 2018, 9:07 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 16 2018, 9:07 AM
Mvolz updated the task description. (Show Details)Feb 16 2018, 9:07 AM
Mvolz updated the task description. (Show Details)
Mvolz updated the task description. (Show Details)
Mvolz updated the task description. (Show Details)Feb 16 2018, 9:10 AM
Deskana triaged this task as High priority.Feb 16 2018, 11:53 AM
Deskana added a subscriber: Deskana.

There was a bug filed for this a few days ago, but I thought it was specifically for third-party installs. This is affecting production, so it's higher priority now. Not quite "Unbreak Now!" since this is not particularly commonly used functionality.

Change 411210 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/core@master] Follow-up I0bb4ed7f7: Use correct 'this'

https://gerrit.wikimedia.org/r/411210

Change 411210 merged by jenkins-bot:
[mediawiki/core@master] Follow-up I0bb4ed7f7: Use correct 'this'

https://gerrit.wikimedia.org/r/411210

Change 411298 had a related patch set uploaded (by Jforrester; owner: Esanders):
[mediawiki/core@wmf/1.31.0-wmf.21] Follow-up I0bb4ed7f7: Use correct 'this'

https://gerrit.wikimedia.org/r/411298

Change 411298 merged by jenkins-bot:
[mediawiki/core@wmf/1.31.0-wmf.21] Follow-up I0bb4ed7f7: Use correct 'this'

https://gerrit.wikimedia.org/r/411298

Mentioned in SAL (#wikimedia-operations) [2018-02-21T00:26:19Z] <thcipriani@tin> Synchronized php-1.31.0-wmf.21/resources/src/mediawiki/mediawiki.ForeignStructuredUpload.js: SWAT: Follow-up I0bb4ed7f7: [[gerrit:411298|Use correct "this"]] T187523 (duration: 01m 13s)

Jdforrester-WMF closed this task as Resolved.Feb 21 2018, 12:29 AM
Jdforrester-WMF raised the priority of this task from High to Unbreak Now!.
Jdforrester-WMF set the point value for this task to 1.
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

Hmm, this should have been UBN status. Oh well.

Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptFeb 21 2018, 12:29 AM
Jdforrester-WMF renamed this task from Unable to upload images in VisualEditor in both Chrome and Firefox on beta and in production to [Regression wmf.21] Unable to upload images in the wikitext and visual editors.Feb 21 2018, 12:34 AM