Page MenuHomePhabricator

Change ko-kp language name
Closed, ResolvedPublic

Description

This task bring text from https://translatewiki.net/wiki/Thread:Support/A_question_about_how_to_change_language_name#A_question_about_how_to_change_language_name_54740

previous discussion: https://translatewiki.net/w/i.php?title=Thread:Support/Korean_language_name_of_ko-kp&lqt_method=thread_history
Hi. Would somebody teach me how to change language name from "한국어 (조선)" to "조선말"? I couldn't find it in CLDR and MessagesKo_kp.php of phabricator. Thanks.

p.s. as far as I know, it is my first time here. So, I don't know whether this is the right place or not.

Event Timeline

Garam created this task.Mar 21 2018, 6:51 PM
Restricted Application added subscribers: revi, Aklapper. · View Herald TranscriptMar 21 2018, 6:51 PM

Hi @Garam, thanks for taking the time to report this and welcome to Phabricator! Please see and follow https://mediawiki.org/wiki/How_to_report_a_bug . We do not know where you see that language name as this task is missing any steps to reproduce. Thanks a lot!

Garam added a comment.Mar 21 2018, 8:44 PM

@Aklapper: We can see it in Translate Wiki (e.g. {#languagename: {{UILANGCODE}} }} or <translate>) and Wikimedia projects (e.g. commons) etc. Thanks.

Garam added a comment.Mar 24 2018, 5:25 PM

Now in this situation, what should I do for this?

p.s. as per standard of spacing words of North Korea, spelling of term "조선 민주주의 인민 공화국 원" ("KPW") is wrong in wmflabs In this case, correct spelling is "조선민주주의인민공화국 원". (see also: ko-wp)

Thanks.

Amire80 renamed this task from A question about how to change language name to Change ko-kp language name.Mar 24 2018, 7:07 PM
Amire80 added a project: I18n.
Amire80 moved this task from Untriaged to Language names and databases on the I18n board.
revi added a comment.Mar 25 2018, 4:22 AM

Politics aside, request LGTM.

Now in this situation, what should I do for this?
p.s. as per standard of spacing words of North Korea, spelling of term "조선 민주주의 인민 공화국 원" ("KPW") is wrong in wmflabs In this case, correct spelling is "조선민주주의인민공화국 원". (see also: ko-wp)
Thanks.

This is not really relevant for this discussion, because this is copied from CLDR, which is an external database. Maybe CLDR can be changed upstream.

For the language name in MediaWiki and software directly related to it, one needs to change it in the GitHub language-data repository using a usual GitHub pull request and in the languages/data/Names.php file in the Gerrit MediaWiki core repository (see Gerrit and Gerrit/Getting started). We plan to unify these files some day, but it's complicated.

revi claimed this task.Mar 25 2018, 7:36 AM

Taking the GitHub and Gerrit patches.

Restricted Application added a project: User-revi. · View Herald TranscriptMar 25 2018, 7:36 AM
revi moved this task from Incoming to Doing on the User-revi board.Mar 25 2018, 7:36 AM

Change 421783 had a related patch set uploaded (by Revi; owner: Revi):
[mediawiki/core@master] Change language name of ko-kp to 조선말

https://gerrit.wikimedia.org/r/421783

revi triaged this task as Normal priority.Mar 25 2018, 7:57 AM

Change 421783 merged by jenkins-bot:
[mediawiki/core@master] Change language name of ko-kp to 조선말

https://gerrit.wikimedia.org/r/421783

revi closed this task as Resolved.May 18 2018, 8:05 PM
revi moved this task from Doing to Closed on the User-revi board.

CLDR is outside the scope for this bug — that’s for Unicode submission and CLDR works independently from mediawiki.

What can be changed on mediawiki (language-data and core) was changed. Closing.