Page MenuHomePhabricator

Raster image in an SVG not displayed (due to invalid MIME type "image/jpg")
Closed, InvalidPublic

Description

The rasterimmage of
https://commons.wikimedia.org/wiki/File:Barents_Sea_map_hr.svg
does not render at all. (Version of 11:58, 5. Mai 2018)

How it is rendered

How it should render

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE svg PUBLIC '-W3CDTD SVG 1.1EN' 'http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd'>
<svg viewBox="0 0 1200 1098" width="1200" height="1098" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink">
<image width="1200" height="1098" xlink:href="data:image/jpg;base64,/9j/4AAQSkZJRgABAQEASABIAAD/2wBDAAMCAgMCAgMDAwMEAwMEBQgF
[...]
[...]
[...]
/E0f8K78K/8AQtaR/wCAMX/xNaU6VOk7wjYXNc
2Q=="/>
</svg>

mistake found: (jpg instead of jpeg)
useses xlink:href="data:image/jpg;base64, instead of xlink:href="data:image/jpeg;base64,

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 5 2018, 12:48 PM
JoKalliauer renamed this task from raster immage in an svg not displayed to raster image in an svg not displayed.May 5 2018, 12:57 PM
JoKalliauer updated the task description. (Show Details)
JoKalliauer updated the task description. (Show Details)May 5 2018, 8:25 PM
Restricted Application added projects: Commons, Multimedia. · View Herald TranscriptMay 5 2018, 10:55 PM
Glrx added a subscriber: Glrx.EditedMay 6 2018, 12:09 AM

data: should be followed with a MIME type.

"image/jpg" is not a valid MIME type, so this is not a bug and can be closed.

"image/jpeg" is the appropriate MIME type.

see https://developer.mozilla.org/en-US/docs/Web/HTTP/Basics_of_HTTP/Data_URIs

either the MIME type is given or it defaults to "text/plain..."

MIME type defined:
https://www.iana.org/assignments/media-types/media-types.xhtml
does not define JPEG but links to
https://tools.ietf.org/html/rfc2046
which uses "image/jpeg"

JoKalliauer closed this task as Invalid.May 6 2018, 8:27 AM
Aklapper renamed this task from raster image in an svg not displayed to Raster image in an SVG not displayed (due to invalid MIME type "image/jpg").May 7 2018, 10:23 AM
Vvjjkkii renamed this task from Raster image in an SVG not displayed (due to invalid MIME type "image/jpg") to ekdaaaaaaa.Jul 1 2018, 1:11 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
JoKalliauer renamed this task from ekdaaaaaaa to Raster image in an SVG not displayed (due to invalid MIME type "image/jpg").Jul 1 2018, 7:22 AM
JoKalliauer closed this task as Invalid.
JoKalliauer lowered the priority of this task from High to Low.
JoKalliauer updated the task description. (Show Details)
JoKalliauer added a subscriber: Aklapper.
JoKalliauer updated the task description. (Show Details)Jul 22 2018, 9:31 AM