Page MenuHomePhabricator

Merge #Pywikibot-General to #Pywikibot-core
Closed, ResolvedPublic

Description

There are several main parts of Pywikibot framework:

For all of these we have got some kind of Phabricator project, but for the main framework, we use two projects, which are kind of duplicate.

Per T170090 we would like to ask for merging project Pywikibot-General into Pywikibot.

Event Timeline

Dvorapa triaged this task as Lowest priority.May 29 2018, 2:47 PM
Dvorapa created this task.
Dvorapa updated the task description. (Show Details)May 29 2018, 2:50 PM
Dvorapa updated the task description. (Show Details)
Dvorapa moved this task from Incoming to Projects to change / set on the Project-Admins board.
Dvorapa raised the priority of this task from Lowest to Needs Triage.May 29 2018, 2:54 PM

Just to make sure, has there been public discussion among the Pywikibot maintainers?
Merging basically means mass re-tagging (probably via the @Phabricator_maintenance account) and then archiving one project.

Dvorapa added a comment.EditedMay 29 2018, 3:42 PM

You can see the task mentioned above. We can also create special RfC subtask and discuss further if needed. The key is that Pywikibot-General is not used for its purpose, we use Pywikibot instead.

Xqt added a comment.Jun 19 2018, 8:58 PM

I guess we can ignore tasks which have a pywikibot-compat Tag.

I guess we can ignore tasks which have a pywikibot-compat Tag.

Alright! That reduces the number of tasks to update from 191 to 137: https://phabricator.wikimedia.org/maniphest/query/ss2xhoehLWgT/#R

Aklapper closed this task as Resolved.EditedJun 29 2018, 3:23 PM
Aklapper mentioned this in Pywikibot-General.

Please note: Anyone with batch-edit permissions can perform such mass-moves, archive a project and update the project description.

No Phab admin needed (except for global Herald rules). :)

MarcoAurelio added a comment.EditedJun 30 2018, 9:14 AM

@Aklapper If we're going to remove (do we need to remove the tag?) Pywikibot-General from a lot of tasks, there's a nice CLI command to do so silently and I think people would appreciate if we did so that way to avoid spamming. There are ~490 tasks with that project a.t.m.

I have created the work daemon and it should be accesible at:

phabricator/ $ ./bin/bulk make-silent --id 1459

Of course, I repeat, that in case we really need to remove the tag.

About a global Herald rule, I think I can create one to remove this archived tag from new tasks and substitute it with Pywikibot.

I don't see a need to "remove" (a feature that does not exist) that tag.

I don't see a need to "remove" (a feature that does not exist) that tag.

Sorry but this does not help. I think the message is clear as to what was proposed: remove the tag from existing tasks.

We can certainly keep the tag on the tasks the same way we did with Shell if it is not a problem.

What about a Herald rule to prevent its adition in the future? Do we have recent examples where this tag got added on new tasks? If not, maybe it's not worth the effort either.

Sorry but this does not help. I think the message is clear as to what was proposed: remove the tag from existing tasks.

Where does it say so and which problem does that solve?

Where does it say so [...]

T195856#4326765 first line: "if we're going to remove [the deprecated tag] from a lot of tasks".

That makes it clear what the request was IMHO: remove the tag from tasks, not remove (delete) the tag from the system (which I was not requesting that, not now, not ever). I am not sure what led you to believe that I was requesting such a thing.

which problem does that solve?

I also asked that question in my first comment, first line, in parenthesis, above; before you came with the "the feature does not exist" comment. The old tag can certainly be kept the same way we did with Shell as I noted above.

Vvjjkkii renamed this task from Merge #Pywikibot-General to #Pywikibot-core to v2baaaaaaa.Jul 1 2018, 1:07 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii removed Aklapper as the assignee of this task.
Vvjjkkii raised the priority of this task from Low to High.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed subscribers: Aklapper, MarcoAurelio.
RichSmith renamed this task from v2baaaaaaa to Merge #Pywikibot-General to #Pywikibot-core.Jul 1 2018, 7:17 AM
RichSmith closed this task as Resolved.
RichSmith assigned this task to Aklapper.
RichSmith lowered the priority of this task from High to Low.
RichSmith updated the task description. (Show Details)
RichSmith added subscribers: Aklapper, MarcoAurelio.

Recently the tag was sometimes also used by novice bug reporters, yes. But I don't think we have to remove the tag from existing tasks, only from the new ones. It should be relatively easy to keep track of those tasks and do it by hand, but Herald rule can also help.

The Pywikibot-General tag is archived so it is not offered by default in project auto-completion dropdown proposals (only if you explicitly enter the complete name). There might be URLs out there on wikis etc linking to it to create tasks etc, but I don't see how removing the tag helps as that would only lead to `??? (Unknown Object)` being displayed in the project tags field in the task creation form.
We can set up a Herald rule to remove the Pywikibot-General tag on newly created tasks and add Pywikibot instead if that is wanted, yes.

I still don't understand which actual problem is solved by removing the tag from existing tasks, sorry... :-/

Dear Andre. There is not a problem with leaving Pywikibot-General in the tasks. It was intended to be a question. Sort of: hey, if we need and only if we needed to remove the tag (it seems it is not necesary and that's okay) then I have constructed this job to do that quickly and noiseless. Like I said, I see there's no need to remove such tag from the tasks. That's okay. Regards.

Ah. Sorry! And thanks for clarifying! If we need to do mass-changes that are not interesting to anybody (like mass-removing an archived tag) some folks (me included) have access to the @Phabricator_maintenance account which will not trigger any notifications and be silent. So yes it is possible. :)